Page 1 of 3 123 Last
  • Jump to page:
    #1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2008
    Posts
    195
    Rep Power
    7

    Some cisco questions...?


    Ok so i will put some cisco questions here... im getting quite into cisco so i think i will post a bit here...

    My first issue, a bit of a biggie, and annoying

    is TELNET (i know its not the most secure)

    but im trying to configure telnet on my 1841. And i can get it working....but

    I configure every

    en
    conf t
    no ip domain-lookup

    int fa0/1
    ip address 10.0.2.250 255.255.255.0
    no shutdown

    hostname ROUTER1

    line vty 0
    password cisco
    login

    line vty 1
    password cisco
    login

    wr mem

    copy run start

    copy run flash

    why when i reboot the router all configuration is the same EXCEPT i cannot telnet into the router anymore....however with this configuration before reboot..i can telnet into it

    THANKS!!
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2005
    Can you post a sh run output before and after reboot?
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2008
    Posts
    195
    Rep Power
    7
    Sure

    Config before reboot, Line vty configured wr mem and copy run start

    router1#sh run
    Building configuration...

    Current configuration : 713 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname router1
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$14wM$PO8QuSMlKJ/hNgztF8vw/1
    !
    no aaa new-model
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    multilink bundle-name authenticated
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 10.0.2.250 255.255.255.0
    duplex auto
    speed auto
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    !
    !
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 1
    password cisco
    login
    line vty 2 4
    login
    !
    scheduler allocate 20000 1000
    end

    Config after reboot.

    System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 2006 by cisco Systems, Inc.
    PLD version 0x10
    GIO ASIC version 0x127
    c1841 platform with 131072 Kbytes of main memory
    Main memory is configured to 64 bit mode with parity disabled


    Readonly ROMMON initialized
    program load complete, entry point: 0x8000f000, size: 0xcb80
    program load complete, entry point: 0x8000f000, size: 0xcb80

    program load complete, entry point: 0x8000f000, size: 0x15d4270
    Self decompressing the image : #################################################################################################### ################## [OK]

    Smart Init is enabled
    smart init is sizing iomem
    ID MEMORY_REQ TYPE
    0X003AA110 public buffer pools
    0X00211000 public particle pools
    0X000021B8 Onboard USB

    If any of the above Memory Requirements are
    "UNKNOWN", you may be using an unsupported
    configuration or there is a software problem and
    system operation may be compromised.

    Allocating additional 6691343 bytes to IO Memory.
    PMem allocated: 118489088 bytes; IOMem allocated: 15728640 bytes

    Restricted Rights Legend

    Use, duplication, or disclosure by the Government is
    subject to restrictions as set forth in subparagraph
    (c) of the Commercial Computer Software - Restricted
    Rights clause at FAR sec. 52.227-19 and subparagraph
    (c) (1) (ii) of the Rights in Technical Data and Computer
    Software clause at DFARS sec. 252.227-7013.

    cisco Systems, Inc.
    170 West Tasman Drive
    San Jose, California 95134-1706



    Cisco IOS Software, 1841 Software (C1841-BROADBAND-M), Version 12.4(15)T8, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Mon 01-Dec-08 13:54 by prod_rel_team
    Image text-base: 0x6008195C, data-base: 0x61901C00

    Cisco 1841 (revision 7.0) with 115712K/15360K bytes of memory.
    Processor board ID FHK133073EU
    2 FastEthernet interfaces
    DRAM configuration is 64 bits wide with parity disabled.
    191K bytes of NVRAM.
    62720K bytes of ATA CompactFlash (Read/Write)



    Press RETURN to get started!

    router1#sh run
    Building configuration...

    Current configuration : 713 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname router1
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$14wM$PO8QuSMlKJ/hNgztF8vw/1
    !
    no aaa new-model
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    multilink bundle-name authenticated
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 10.0.2.250 255.255.255.0
    duplex auto
    speed auto
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    !
    !
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 1
    password cisco
    login
    line vty 2 4
    login
    !
    scheduler allocate 20000 1000
    end

    Thanks!
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2008
    Posts
    195
    Rep Power
    7
    Ok..so went away for the weekend... just got home and tried it again. and its working. Why this is i am really not sure...al i cam think is i was copying the start up config to the running, but this is really not like me, but having said that, maybe i just need a weekend away HAHA!!

    Now, my next little issue which ive had a small issue with prior to this one is.

    I have no DNS when use my 1841 as a router, i cannot even ping interlally from the router itself.

    I try ping 10.0.2.x and 8.8.8.8 with a 0% success rate

    sh ip route displays a default route for network 10.0.2.0

    Any ideas? Cheers
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2005
    Is the router acting as the gateway for your home network to the internet, or is it just setup in a lab? I'm assuming it's setup in a lab environment of sorts since you're able to get online and post replies on this forum. If it's acting as an actual gateway, you should have your default route (0.0.0.0 0.0.0.0 x.x.x.x) set to your public IP address. If it's in a lab environment, you'll want to have the default route set to the local IP of your gateway.

    Also, I'm not sure, but you would probably have to enable ICMP (ping) replys through the firewall to get a response.
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2008
    Posts
    195
    Rep Power
    7
    well right now its in my room, connected via Ethernet and im using the WAN router and the gateway. Aventually i will setup this router to do DHCP and be a ROUTER and possibly put a ADSL WIC in it for the WAN side of things

    Right now its in my room.. connected via ethernet to a wireless access point. All is fine, i can ping it, ive setup DHCP and tested it and its working fine. I just have a ROUTING issue. i must be doing something wrong

    i have done ip route 10.0.2.0 255.255.255.0

    and still i am unable to ping from router to any other device on the network IE the wireless access point, as well as external addressees such as 8.8.8.8 (google public)

    so somethings wrong, how what other routes do i need, there is only one subnet/network which i have added the route for.

    Thanks!
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2008
    Posts
    195
    Rep Power
    7
    also, i thought that a default route was created automatically for the network connected. So ive set int fa0/0 ip address 10.0.2.x i thought this would automatically create a default route for 10.0.2.0

    Thanks for your help man!
  14. #8
  15. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2005
    If you're basically using the Cisco device as another "node" on your network (such as any other computer, tablet, phone, TV, etc...), then it will use the same default gateway as all the other nodes on your network. For example, at my house I have a UVerse modem from AT&T. It's local IP address on my network is 10.10.3.1. As a result, every device gets the IP of their default gateway (via DHCP) as 10.10.3.1; you could also set this statically if you weren't using DHCP for whatever reason on your network.

    Right now you shouldn't need any static routes entered into the 1841 except for the default gateway entry. It will already know about your local network because you've added a local IP address to FA0/0. At that point it will have a route (via Connected interface) to that IP range.

    You will want to enter a static route to 0.0.0.0 0.0.0.0 1.2.3.4 (local ip of your gateway). Configure termnial>ip route static 0.0.0.0 0.0.0.0 1.2.3.4.

    Post a sh ip int brief and sh ip route; along with another show run. I didn't see an entry for a default route in the last show run output you posted. Try setting the default route manually as I suggested above.

    You can ping the local IP of your gateway right?
  16. #9
  17. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2008
    Posts
    195
    Rep Power
    7
    Ok now im convinced something is wrong with this router.

    I took it out, put it in my car this morning and was going to take it into work today to check it out...but after reading your post i thought i would give it another shot...

    I got home, plugged in the power and LAN cable, and now i can PING everything on my network (internally only) which i have not been able to do at all yet.

    So ive been playing with it all night, NO problems, rebooted multiple times, change some config and wr mem copy run start etc, rebooted and all fine....

    THEN, i tried to telnet the router, telnet connected successfully and asked for a password (before enable mode)

    i cancelled and closed cmd, then tried to open another telnet session in CMD and received the following error

    Password required, but none set

    Then, via serial i try to ping any internal host on the network. with a complete failure 0% success rate..

    Localhost, the router itself pings fine. This all started as soon as i tried to telnet the router.

    Im really really confused and LOST with this....i cant see any other explanation other then faulty hardware...?

    any ideas...now im getting quite despirate LOL

    Thanks for your help
  18. #10
  19. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2005
    Did you assign a local IP to your serial interface? You may want to just reset the router and start fresh so you know exactly what point you're starting from. Make a few basic changes, such as hostname and bringing up a few interfaces and adding local IPs to them. Reboot the router to make sure the changes stay.

    Then try a few more steps, reboot, verify they stay, etc...

    If after 2 or 3 reboots they're there it should be fine. I'm not too familiar with troubleshooting Cisco gear, but the above seems like it would help diagnose if there is an NVRAM issue or not. You could also try Googling NVRAM issues for Cisco routers.
  20. #11
  21. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2008
    Posts
    195
    Rep Power
    7
    Originally Posted by seack79
    Did you assign a local IP to your serial interface? You may want to just reset the router and start fresh so you know exactly what point you're starting from. Make a few basic changes, such as hostname and bringing up a few interfaces and adding local IPs to them. Reboot the router to make sure the changes stay.

    Then try a few more steps, reboot, verify they stay, etc...

    If after 2 or 3 reboots they're there it should be fine. I'm not too familiar with troubleshooting Cisco gear, but the above seems like it would help diagnose if there is an NVRAM issue or not. You could also try Googling NVRAM issues for Cisco routers.
    Ok i just reset the router to factory defaults.

    One more quick issue i had, i issued DHCP to give out the routers ip as the gateway for my home network, all clients received a new lease with the router as the gateway via DHCP

    BUT, when the router is plugged in, i loose DNS, even though my DNS server isses via DHCP is completely different then the router

    I can reach the DNS server from any client on the network, and from the router

    If i ping -n 200 www.google.com

    I get time outs until i unplug the router and after 20 seconds or so, i start gettings replys if i plug the router back in, after around 20 seconds or so, timeouts again

    I have not at all been able to ping a top level domain name from the router itself at all

    Any ideas

    Thanks man
  22. #12
  23. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2005
    When you said you reset your router, are you rerferring to the Cisco router or your WAN router provided to you by your ISP?

    Also, which router did you set as your gateway, or were you referring to the Cisco router for the entire above post?
    Last edited by seack79; November 28th, 2012 at 04:37 PM.
  24. #13
  25. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2008
    Posts
    195
    Rep Power
    7
    Sorry, reset the cisco router

    Its so weird....Im am getting DNS, if i try to ping google.com (from local PC with CMD) i get timeouts, however i know DNS is working as it resolves the IP but the ping is not successful


    Pinging google.com [74.125.237.130]with 32 bytes of data:
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.

    Ping statistics for 74.125.237.130:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

    So i initially though, something was blocking ICMP, but im able to ping any local IPs. Also tried to load a webpage with no success.

    Change my gateway back to 192.168.1.1 (my WAN Router), everything is fine instant replys.

    Sorry im sure this is something small but right now i cant use this as a router lol really annoying..

    Thanks!

    Another random ping delivers this result

    Pinging google.com [74.125.237.137] with 32 bytes of data:
    Request timed out.
    Reply from 192.168.1.254: Destination host unreachable.
    Request timed out.
    Request timed out.

    Ping statistics for 74.125.237.137:
    Packets: Sent = 4, Received = 1, Lost = 3 (75% loss),

    one more thing, i have run this command

    conf t
    ip name-server 192.168.1.1
    Last edited by onlinegamesnz; November 28th, 2012 at 10:54 PM.
  26. #14
  27. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2005
    I suspect your issue may be two fold. Can you post another show run. I think the router is blocking icmp replies and your default route isn't setup right.
  28. #15
  29. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2008
    Posts
    195
    Rep Power
    7
    Originally Posted by seack79
    I suspect your issue may be two fold. Can you post another show run. I think the router is blocking icmp replies and your default route isn't setup right.
    Sure mate, current running config

    Router#sh run
    Building configuration...

    Current configuration : 741 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ip name-server 192.168.1.1
    multilink bundle-name authenticated
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.1.254 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    ip default-network 192.168.1.0
    ip forward-protocol nd
    !
    !
    ip http server
    ip nat inside source static 192.168.1.1 255.255.255.0
    !
    !
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    scheduler allocate 20000 1000
    end


    Thanks!!
Page 1 of 3 123 Last
  • Jump to page:

IMN logo majestic logo threadwatch logo seochat tools logo