#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Posts
    3
    Rep Power
    0

    proxy server settings with internet explorer don't work


    Dear All

    No matter what settings I try IE seems to ignore the proxy server.

    It works fine in Opera and mozilla.

    I have a tdsl modem connected into my lan port. So question should I be adjusting the "Dial-Up and Virutal Private Network Settings" or the lan seettings. I have tried both without success.

    I am trying to use a proxy server call "PAW" which is basically a web filter: http://paw-project.sourceforge.net.

    I start the paw server and its address is "localhost" on port "8080".

    I have tried bypass the option try 'bypass proxy sever for local addresses', 'automatically detect settings', again without success.

    Does anyone have any ideas?

    Kinds regards

    kentusha
  2. #2
  3. No Profile Picture
    The Dude Abides
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Feb 2000
    Location
    grass valley,ca
    Posts
    1,062
    Rep Power
    16
    Generally I believe you have to put in the ip address of the proxy server + the port.

    We would need more info on your network setup to be able to tell you more.
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Posts
    3
    Rep Power
    0
    There really is no 'network setup', everything is on one machine. I am connecting to the net through my tdsl directly, on the same machine is the proxy server and the internet explorer.
  6. #4
  7. No Profile Picture
    The Dude Abides
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Feb 2000
    Location
    grass valley,ca
    Posts
    1,062
    Rep Power
    16
    I see, I've never heard of anyone using a proxy server where there is no network, hence the confusion. I see that you are using it as a filter of some sort.

    Try putting in the ip address of your current machine and see if it works then.
  8. #5
  9. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Posts
    6
    Rep Power
    0
    I would like to help you but im confused as to what you are actually trying to accomplish by putting a proxy server on your local machine. Need more info as to how you have it set up.
  10. #6
  11. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Posts
    3
    Rep Power
    0
    Thanks for trying to help. Let me reiterate. I want to start on my machine this thing called paw, which is a proxy server. Paw is basically a web filter for things like images, forms, javascript etc.

    I strongly believe that the paw server is designed so that it can sit on the same machine as the web browser.

    See at the end for more paw info.

    This is what I am doing (all on one machine):
    * I start an internet connection (which automatically opens ie)
    * I start the paw server,
    * start the paw gui (no make sure the server is ok and filtering)
    * open another ie window or mozilla or opera

    I ask server status and the server is running on host: gibson (that is my computer) I go to the server log and it says PAW Server started on port 8080

    To set up your browser to use PAW, you specify your PAW server and port in the Proxy configuration settings (HTTP protocoll) of your browser. ie HTTP Poroxy localhost port 8080

    in explorer I have tried

    * Automatically detect settings
    * in internet options -> connections -> dial-up & virtual private network settings -> user a proxy server for this connection -> address : "localhost" port "8080" -> advanced "user the same proxy server for all protocols"
    *in internet options -> connections -> dial-up & virtual private network settings -> user a proxy server for this connection -> address : "ie 169.254.223.99 ip address from ipconfig" port "8080" advanced "user the same proxy server for all protocols"
    *in internet options -> connections -> LAN settings -> user a proxy server for your lan -> address : "localhost" port "8080" -> advanced "user the same proxy server for all protocols"
    *in internet options -> connections -> LAN settings -> user a proxy server for your lan -> address : " ie 169.254.223.99 ip address from ipconfig" port "8080" --> advanced "user the same proxy server for all protocols"
    * Bypass proxy server for local addresses
    * Use the same proxy server for all protocols
    * installing a service patch: Internet Explorer 6 SP1 Update: Connections No Longer Use Local Area Network Automatic Configuration and Proxy Settings
    This update resolves an issue found where after installation of Internet Explorer 5.0 and later the automatic configuration and proxy setting information for each connection may be separate from the information used for the Local Area Network (LAN) connection

    I have great success with "localhost" "8080" in opera and mozilla, all I do is go to advanced -> proxies and I put in manual proxy configuration, http proxy:localhost port:8080

    one idea i have heard is to is to configure Internet Explorer to use the existing internet connection and establish the
    DSL connection manually, but i do not know how to do this.

    any insights would be grand and sorry for all the details!

    XXXXXXXXXXXXXXXXXXXXXXX

    Paw Information http://paw-project.sourceforge.net

    What is PAW?
    PAW (pro-active webfilter) is an Open-Source filtering HTTP proxy based on the Brazil Framework provided as a Open-Source Project by SUN. Because the Brazil Framework and PAW are written in Java the software is highly portable.

    PAW allows for easy plugin of Handlers (filter outgoing requests) and Filters (filter incoming data - the HTML response) and a GUI for end users. All the configuration files are in XML-Format and thus easy to modify (even without the GUI).

    It's aim is to provide an easy to use interface for end users and to be easily extendable by developers. PAW consists of the followig components:

    PAW Server which implements the filtering HTTP Proxy.

    PAW GUI for easy PAW Server administration.

    *************

    results from IPConfig

    Windows 2000-IP-Konfiguration

    Ethernetadapter "LAN-Verbindung":

    Verbindungsspezifisches DNS-Suffix:
    IP-Adresse (Autokonfiguration). . : 169.254.223.99
    Subnetzmaske. . . . . . . . . . . : 255.255.0.0
    Standardgateway . . . . . . . . . :

    PPP-Adapter "{BC3CBC79-C44A-4E23-A89B-8E43A8453DFF}":

    Verbindungsspezifisches DNS-Suffix:
    IP-Adresse. . . . . . . . . . . . : 217.230.38.68
    Subnetzmaske. . . . . . . . . . . : 255.255.255.255
    Standardgateway . . . . . . . . . : 217.230.38.68

    Ethernetadapter "VMware Network Adapter VMnet1":

    Verbindungsspezifisches DNS-Suffix:
    IP-Adresse. . . . . . . . . . . . : 192.168.146.1
    Subnetzmaske. . . . . . . . . . . : 255.255.255.0
    Standardgateway . . . . . . . . . :

    Ethernetadapter "VMware Network Adapter VMnet8":
  12. #7
  13. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2003
    Posts
    1
    Rep Power
    0

    Lightbulb A couple of thoughts


    I am one of the developers for the PAW server and I am happy to hear someone using it.

    I haven't heard of this specific problem before, however, you are correct that PAW can run on your local machine. In fact that is how I primarily use the software.

    A couple of thoughts.
    1.) Try deselecting the Auto Detect Proxy setting. This may be trying to get to the Internet first, before checking to see if a proxy server is present.

    2.) Try putting 127.0.0.1 for the server address. On some machines localhost doesn't always work.

    3.) Using the PAW GUI, turn logging from 3 (default) to 5 (verbose logging). That way you will see if it is even getting the request from your browser.

    What is interesting is that usually when a proxy server doesn't respond to an Internet browser, you would see a "Server unavailable" message.

    If it still doesn't work for you, let me know.

IMN logo majestic logo threadwatch logo seochat tools logo