#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2013
    Posts
    1
    Rep Power
    0

    Help with Japanese characters in Oracle


    Hi,

    I have a XML file which contains Japanese characters and it is parsed by a unix script and nawk utlity and writes the data to a flat file separated by delimiter. I could the Japanese characters proper in the flat file.

    I use SQLoader (within a unix script) to import this data from the flat file to Oracle database. If I view the data in the database through Toad, the Japanese characters are showing differently (not as in XML or in flat file).

    But if do a export for the particular table to a flat file through Toad, I can see the Japanese characters proper in the exported flat file.

    (Note : I have set the env variables NLS_LANG=Japanese_Japan.JA16SJIS, LC_CTYPE="en_CA.UTF-8" in both XML parser and the loader script)

    Can you please let me know the reason why I couln't see the Japanese characters while viewing through Toad.

    Thanks,
    Srini
  2. #2
  3. Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Sep 2006
    Posts
    857
    Rep Power
    388
    Originally Posted by tsrini123
    Hi,

    I have a XML . . . E t c . . .
    Can you please let me know the reason why I couln't see the Japanese characters while viewing through Toad.
    I suspect it may be due to the MS Windoze code page?

IMN logo majestic logo threadwatch logo seochat tools logo