#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2004
    Posts
    15
    Rep Power
    0

    Oracle Reports 6i -- Runtime Parameter Form displayed at runtime


    Hi everyone,

    When you are in Reports Builder you can configure the Runtime Parameter Form to be displayed at runtime, allowing users to modify parameters, and run the report with those modified parameters (configuration steps: Tools --> Preferences --> Parameter Form box checked under the Runtime Settings).

    I am running the reports on the JRun Web server using the Reports Servlet. The reports without Runtime parameters are working fine, however for those with Runtime Parameters, the Runtime Parameter Form is not displayed and the reports are running without allowing me to modify them.

    Is there a way to force the Runtime Parameter Form to be displayed at runtime when running the reports on the Web using Reports Servlet? Or, alternatively, is it possible using the Oracle WebDB server (which, by the way, I would like to know if it is available for download, and where)? I would rather prefer to use the former web publishing method.

    Thanks in advance,

    Paul
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2004
    Posts
    15
    Rep Power
    0
    I found it.

    It was as simple as adding to the URL that invokes the report using the RWServlet.class the parameter &PARAMFORM=YES, which means show the Parameter Form at runtime.

    Paul
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2004
    Posts
    2
    Rep Power
    0

    Thumbs down Oracle Report Parameter Form on Web????? ... it's very important


    Originally Posted by 01miner
    I found it.

    It was as simple as adding to the URL that invokes the report using the RWServlet.class the parameter &PARAMFORM=YES, which means show the Parameter Form at runtime.

    Paul
    As far as you are concerned about Reports Servelet, I havnt tested it.
    Im using cgi.exe Program on Web Server. Problem is when i pass &paramform=HTML as parameter, browser displays the Report Parameter Form as HTML output. Till here its all fine.
    But for database LOVs (dynamic LOVs) it displays just a text field with all LOV values as text just below the text field.

    Can I get the report parameter form as i get in Report Runtime Environment.

    Waiting for your swift reply..

    Regards,
    Hasan
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2004
    Posts
    2
    Rep Power
    0
    Im waiting for a qiuck Reply

    Thanks

IMN logo majestic logo threadwatch logo seochat tools logo