#1
  1. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Location
    New Zealand
    Posts
    295
    Rep Power
    19

    Oracle 9i TNS:could not resolve service name.. Newbie help


    Hi I have a few questions about setting Oracle 9i up

    first of all I have installed this on a local machine that is not part of a network to run on a local machine..

    a) I want to use sql*Plus to create a database tables etc.. which i cannot do by the looks until i set up Net configuration. But when i try to set up the Net Service name i have recieved this message -> TNS:could not resolve service name "About 10 Zillion times"

    so thats problem 1..

    now do i need to create a database before I do this? by running the database configuration Assistant?

    help would be appreciated

    cheers Dirk
  2. #2
  3. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Location
    New Zealand
    Posts
    295
    Rep Power
    19
    Ok it appears that installing another database has fixed that problem.. but now i get Invalid username and password for just about everything I try to do on it..

    Where can i manage users of this database to fix these problems? can anybody help?

    Dirk
  4. #3
  5. No Profile Picture
    Senior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Location
    Canada
    Posts
    308
    Rep Power
    12
    You suppose to connect with Oracle database as SYSTEM/ password OR SYSTEM/password as sysdba, as follows:

    C/>sqlplus system/password as sysdba

    If you get the SQL prompt withour having any problem then you can change the password of any existing user in the database, an example is given below:

    SQL>alter user scott identified by myself;

    now try to connect with that user.


    Regards
  6. #4
  7. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Location
    New Zealand
    Posts
    295
    Rep Power
    19
    Thanks i finally stumbled across Sysdba and added a user in the enterprise management console so now i can run with user Admin..

    But im not sure, does management console require a repository database to be running so you can use it..

    thanks for the reply by the way..

    I take it Sysdba can be run because it Authenticates with Windows NT and your local user.
    I cant seem to add users in the windows Authentication console tho... well let me rephrase that, I can add them but they dont work :-)

    Dirk

IMN logo majestic logo threadwatch logo seochat tools logo