#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2003
    Location
    Canada
    Posts
    94
    Rep Power
    22

    Weird Oracle error...


    Hi Everyone,

    I am having some trouble figuring out what this error might be. I have a service that executes a pl/sql function (legacy app) to delete records from multiple tables. This function works fine in development, and has worked fine in production until about a week ago. I'm not a DB guy but the DB guys are trying to say this is an application issue. That may be, be the "insuff privileges" really leads me to believe otherwise.

    Any ideas what is causing this type of Oracle error? Permissions between dev and prod are the same, yet it works in dev but not prod.


    Code:
    
    ORA-29876: failed in the execution of the ODCIINDEXDELETE routine
    ORA-20000: Oracle Text error:
    DRG-50857: oracle error in textindexmethods.ODCIIndexDelete
    ORA-20000: Oracle Text error:
    DRG-10602: failed to queue DML change to column ABSTRACT for primary key AAAfBoAAEAABa62AAA
    DRG-50857: oracle error in drexrdml
    ORA-01031: insufficient privileges
    
    ORA-06512: at "CTXSYS.DRUE", line 160
    ORA-06512: at "CTXSYS.TEXTINDEXMETHODS", line 656
    ORA-06512: at "SCHEMA.PLSQL_PKG", line 697
    ORA-06512: at line 1
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2010
    Location
    Vienna, Austria
    Posts
    58
    Rep Power
    5
    Hi,

    are you sure, the user on PROD does not only have the same system privileges, but also has the same object privileges (looks like there is no CTXAPP role assigned) ?
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2003
    Location
    Canada
    Posts
    94
    Rep Power
    22
    Originally Posted by magicwand
    Hi,

    are you sure, the user on PROD does not only have the same system privileges, but also has the same object privileges (looks like there is no CTXAPP role assigned) ?
    Yeah, I checked that earlier and yet still the same error.

IMN logo majestic logo threadwatch logo seochat tools logo