I am trying to run perl on a Win CE Allen Bradley Panel View Plus HMI

It has Win CE 6.0

I tried 2 binaries which I downloaded they are perl-wince-x86-palm-wce211 and perl-wince-x86-pocket-wce300

I had found the following installer and tried it, (the device didn't seem to have the registry command so I couldn't do the registry bits but I thought it might run anyway my script with perl anyway.

\Storage Card2\ is where the bin and lib directories are located.

@echo off
copy \Storage Card2\bin\perl.dll \Windows
set perlexe="\Storage Card2\bin\perl.exe"
set perllib="\Storage Card2\lib\perl5"
cereg -k "HKLM\Environment" -n "PERL5LIB" -v "%perllib%"
cereg -k "HKCR\.pl" -n "" -v "perlfile"
cereg -k "HKCR\perlfile" -n "" -v "Perl Script"
cereg -k "HKCR\perlfile\DefaultIcon" -n "" -v "%perlexe%. -l"
cereg -k "HKCR\perlfile\Shell\open\command" -n "" -v "%perlexe%. %%1"

It runs the perl file but doesn't do the actions the same thing works fine on my windows 10 laptop so I think I may have the wrong binary

my processor shows as Genuine Intel i486-UN 450 @ 1.66GHz.

Any advise appreciated.