#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2013
    Posts
    16
    Rep Power
    0

    Imagemagick and perlmagick not working together


    Hello

    I am developing a Ubuntu server dedicated to a webcam application. I run a number of perl scripts to manage the images. A couple of these scripts use perlmagick to interface with imagemagick.

    The problem is that these scripts used to work and now they don't. I don't know what has happened to stop them working. All I have done is a couple of apt-get upgrades. None of those appear to be related to imagemagick.

    The error messages start with " Can't locate object method ..."
    Full details are posted here: Ubuntu Forum

    A search of the web shows this type of error message is not uncommon but most calls for help go unanswered.

    As far as I can figure out, either the versions of imagemagick and perlmagick are not compatible, or perlmagick doesn't have the right path to find the right files.

    One of the error messages refers to file "composite.al". Google can't find a reference to "auto/Image/Magick/composite.al". I can't find this file on my server.

    I was thinking about reinstallind perl, perlmagick and imagemagick but adice from the web said that remove/installing perl was a bad thing to do.


    I am stuck. Any advice would be appreciated.

    Dazz
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2013
    Posts
    16
    Rep Power
    0
    Hi

    Some more rummaging around the web has revealed that Imagegraphics and installation/change problems are not uncommon.

    For my remote webcam application, stability and reliability are very important. I am going to switch to Graphicsmagick which does what I want and has a reputation for better stability.

    Dazz

IMN logo majestic logo spyfu logo threadwatch logo seochat tools logo