I'm currently trying to import an .avi file into my CS4 extended photoshop program. Every time I go to File > Import > Video Frames as Layers, it tells me that it "Could not complete the Video Frames to Layers command because QuickTime version 7.1 or later is required"

That's all fine and good, except I have QuickTime 7.7, and it is fully updated. Photoshop is still telling me that I can't do it. Can anyone help me?