#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Posts
    2
    Rep Power
    0
    I installed MySQL/PhP running on linux and apache 1.3.9 and I believe the installation may be faulty. MySQl works fine, but when I test any php script on any of my virtual domains it fails. I made all the recommended changes to httpd.conf, mime.types and I also have frontpage extensions on my virtual domains. Any ideas why my php fails to execute. The directory I copied the php3.ini file is /etc/httpd and php is installed on /usr/local. I have all the recommended libraries installed. If anyone is very familiar with my problem I may even be willing to pay for their services if possible.
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2000
    Posts
    33
    Rep Power
    15
    It seems you are building PHP as a module for Apache (php.ini has to be copied with this type of installation). Can you probably try and build Apache with PHP (together)? I did the same configuration on my machine (though I don't have any virtual servers, but that's on the side of Apache, not PHP). Does Apache work fine?
    Anyway, try to compile Apache with PHP and then if you have mistakes you can probably find the problem more easily.
    Good luck, Stas

Similar Threads

  1. Replies: 2
    Last Post: August 18th, 2004, 10:45 PM
  2. Replies: 4
    Last Post: January 28th, 2004, 08:29 AM
  3. PHP with UnixODBC
    By coder4hire in forum PHP Development
    Replies: 2
    Last Post: January 20th, 2004, 01:14 PM
  4. Passing string from PHP to Javascript
    By ka8oad in forum JavaScript Development
    Replies: 4
    Last Post: January 17th, 2004, 03:12 PM
  5. UnixODBC + PHP + Apache + Empress
    By coder4hire in forum Database Management
    Replies: 0
    Last Post: January 15th, 2004, 01:41 PM

IMN logo majestic logo threadwatch logo seochat tools logo