1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2000
    Rep Power
    mail("xxx@xxx.com","Just for test",$message,"From:root@localhostnReply-To:xxx@xxx.comnX-Mailer:PHP/".phpversion());
    The mail always in the Mail Queue, never send.
    []# telnet localhost 25
    MAIL FROM:baba@localhost ------OK
    RCPT TO:xxx@xxx.com -----------OK
    Same problem, the mail always in the queue.
    []# ps -x | more
    sendmail:accepting connections on port 25
    ---------Sendmail is actived
    What's wrong with my MAIL system ?
  2. #2
  3. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Rep Power
    I have posted a longer reply to a very similar question (asked Jun 1st I think) today. Nothing is wron with your mail- settings. You should have a look in /var/log/mail. Maybe you see the explanation in there.
    To make it short in the net, only emails having a valid sender- Domain can be forwarded. All others are blocked ! Localhost or localdomain is NOT a valid (Internic- registered domain). However you might be able to modifie sendmail.cw in a way to forward it in your local INTRAnet. But in the INTERnet there is no way.

    Joerg Fritsch

Similar Threads

  1. Help with script
    By akastarlight in forum Perl Programming
    Replies: 1
    Last Post: February 6th, 2004, 06:55 AM
  2. Replies: 2
    Last Post: December 23rd, 2003, 11:50 PM
  3. I could not send mail
    By go_tech in forum PHP Development
    Replies: 1
    Last Post: December 10th, 2003, 04:44 PM
  4. loop through customer file and send mail
    By josephg in forum Visual Basic Programming
    Replies: 10
    Last Post: October 27th, 2003, 07:40 PM
  5. Sending Email Directly to a mail queue
    By leslie.owensby in forum PHP Development
    Replies: 1
    Last Post: October 17th, 2003, 08:15 AM

IMN logo majestic logo threadwatch logo seochat tools logo