Thread: configure error

    #1
  1. No Profile Picture
    Ulrik N
    Guest
    Devshed Newbie (0 - 499 posts)
    err..

    When I do the;
    ./configure --with-apxs=/usr/local/apache/bin/apxs --with-config-file-path=/etc/httpd --with-mysql --with-system-regex

    I get this error:
    "configure: error: Invalid MySql directory - unable to find mysql.h"

    What do I have to do??
    the "mysql.h" file is locatet here: "/usr/local/mysql/include/mysql.h"

    ------------------
    -ulrik-
  2. #2
  3. No Profile Picture
    jpenix
    Guest
    Devshed Newbie (0 - 499 posts)
    The problem is that Linux doesn't know to look in that directory for add-on libraries such as MySQL.

    Edit /etc/ld.so.conf and add this line:

    /usr/local/mysql/include

    Then run 'ldconfig' to commit the changes to the system.

    Recompile and you should be okay!

    (BTW: All of the above will have to be done as root)
  4. #3
  5. No Profile Picture
    Ulrik N
    Guest
    Devshed Newbie (0 - 499 posts)
    Thanks, but it still don't work!

    If you need nore info:
    I'm using RedHat6.0
    I have installed MySql with no problems,
    the same goes for Apache....

    Anything else I need to do.?

    ------------------
    -ulrik-
  6. #4
  7. No Profile Picture
    Falcula
    Guest
    Devshed Newbie (0 - 499 posts)
    If you are using RedHat RPM's it could be that you are missing the source for MySQL. The INSTALL.REDHAT file that came with PHP tar file has more information on it. I installed the source and development RPM's and it solved the problem.

    ------------------
  8. #5
  9. No Profile Picture
    Ulrik N
    Guest
    Devshed Newbie (0 - 499 posts)
    No I'm not using RPM's. I was told that the best way to doo this was to compile the binary distribution.
    I was following the tutorial found at devshed.com called "Setting Up Database Driven Websites"
    With one exeption, I was using the latest versions of php3, mysql and apache!

    Other suggestions?


    ------------------
    -ulrik-
  10. #6
  11. No Profile Picture
    jpenix
    Guest
    Devshed Newbie (0 - 499 posts)
    These instructions blow by when you run 'make install' during the MySQL installation. Perhaps they hold the key to your problems:

    Libraries have been installed in:
    /usr/local/mysql/lib/mysql

    If you ever happen to want to link against installed libraries
    in a given directory, LIBDIR, you must either use libtool, and
    specify the full pathname of the library, or use `-LLIBDIR'
    flag during linking and do at least one of the following:
    - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
    during execution
    - add LIBDIR to the `LD_RUN_PATH' environment variable
    during linking
    - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
    - have your system administrator add LIBDIR to `/etc/ld.so.conf'

    See any operating system documentation about shared libraries for
    more information, such as the ld(1) and ld.so(8) manual pages.
  12. #7
  13. No Profile Picture
    Ulrik N
    Guest
    Devshed Newbie (0 - 499 posts)
    Thank you all...

    I found out myself
    "--with-mysql=/usr/local/mysql/"

    this did the trick...




    ------------------
    -ulrik-

Similar Threads

  1. Codepupil
    By Adachic in forum C Programming
    Replies: 3
    Last Post: February 6th, 2004, 06:50 PM
  2. syntax error : identifer 'Hole'
    By bootrecker in forum C Programming
    Replies: 2
    Last Post: February 2nd, 2004, 08:08 AM
  3. Replies: 4
    Last Post: January 28th, 2004, 08:29 AM
  4. mysql: getting error description from error code
    By laker in forum PHP Development
    Replies: 1
    Last Post: January 21st, 2004, 06:03 AM
  5. I don't know what this error message means
    By lcham02 in forum Java Help
    Replies: 2
    Last Post: January 13th, 2004, 11:57 AM

IMN logo majestic logo threadwatch logo seochat tools logo