Thread: Fata Error

    #1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2013
    Posts
    5
    Rep Power
    0

    Fata Error


    Hi

    I am new to PHP coding,

    I have installed Apache 2.2, PHP 5.4.17 and MySQL 5.5.32 on my windows 7.

    Is was successfully installed and am able to see "Its Works" but "Fatal error: Call to undefined function mb_detect_encoding() in C:\websites\phpmyadmin\libraries\php-gettext\gettext.inc on line 177 " occur while trying to launch "http://localhost/myphpadmin/index.php"

    Would appreciate if anyone can help.

    Thanks in advance
  2. #2
  3. Did you steal it?
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    13,997
    Rep Power
    9397
    You need the mbstring extension enabled - check your php.ini.

    You need other things too. phpMyAdmin requirements
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2013
    Posts
    5
    Rep Power
    0
    Hi,

    Thanks, I've done this:
    ;extension=php_ldap.dll

    extension=php_mbstring.dll

    ;extension=php_exif.dll

    extension=php_mysql.dll
    extension=php_mysqli.dll

    ;extension=php_oci8.dll

    I still get the same error. Appreciate your help.

    Thanks in advance
  6. #4
  7. Did you steal it?
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    13,997
    Rep Power
    9397
    Did you restart Apache? Are you sure you edited the right file?
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2013
    Posts
    5
    Rep Power
    0
    Hi

    I did restart Apache and the edit was done on php.ini

    Thanks
  10. #6
  11. Did you steal it?
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    13,997
    Rep Power
    9397
    Use phpinfo() to see what is installed. If it doesn't list mbstring then it isn't enabled. While you're there it tells you what php.ini it used: make sure you edit that one.
  12. #7
  13. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2013
    Posts
    5
    Rep Power
    0
    Hi

    It wasn't listed.

    had edit on the correct php.ini
  14. #8
  15. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2013
    Posts
    5
    Rep Power
    0
    Hi

    Error cleared.

    instead of using the file name "php.ini" replace it with "config.ini" and is working fine now.

IMN logo majestic logo threadwatch logo seochat tools logo