#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2000
    Location
    Beijing,PRC
    Posts
    7
    Rep Power
    0
    Hi there,
    I installed php_3.0.13 (at chp3) and apache(at c:apache) on my computer this morning(Win98), they all worked fine.
    Then I installed Mysql(at c:mysql) and modified c:windowsphp3.ini ,deleted ';' before "extension=php3_mysql.dll".
    After doing all these steps listed in the php manual , I used phpinfo() to check. But in the first part of the report , I couldn't find any thing about Mysql, instead , I found a line of "ODBC" where I considered should be Mysql. It seemed that mysql module was not loaded. So I added a line in the script using "dl(php3_mysql.dll);", this time it gave me this :
    Fatal error: Unable to load dynamic library 'Chp3php3_mysql.dll'
    I copied all those .dll files to windowssystem , but it didn't work.

    who can help me out ? thx!
  2. #2
  3. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2000
    Location
    Mexico DF Mexico
    Posts
    16
    Rep Power
    0
    Hi, well mine worked at the first install, just remove the ; from the php3.ini, in the mysql dll file and before using Mysql run the Mysql daemon, Ill recomend going out to DOS and going to the mysql folder
    cd..
    cd mysql
    and type c:mysql> mysqld
    and then to check its running type
    mysql and if youre in its working..

    Ho and check that you have all the PHP3_*.dll that are listed in the php3.ini inyour php install folder chp3

    Regards

    [This message has been edited by ltena (edited January 16, 2000).]
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2000
    Location
    Beijing,PRC
    Posts
    7
    Rep Power
    0
    Hi, Itena, thanks for your help. I'm very sure Mysql worked well ('cause i've set up a database with it). But I still cannot make php work with it.
    I couldn't stand on it any more , so I went to php.net and download php_3.0.14 and installed it. woooo! It worked! hehe.
    I think 3.0.14's readme and .ini_inst improve a lot , clear and easy.
    thank u all the same.

Similar Threads

  1. Replies: 10
    Last Post: May 13th, 2004, 06:38 PM
  2. working with ODBC
    By jp1234 in forum Oracle Development
    Replies: 0
    Last Post: February 1st, 2004, 02:26 PM
  3. Add (no) of working days only to a date
    By newbie10 in forum PHP Development
    Replies: 4
    Last Post: January 15th, 2004, 04:45 AM
  4. LAN not working
    By dave2k in forum Computer Hardware
    Replies: 1
    Last Post: January 11th, 2004, 04:18 AM
  5. Replies: 8
    Last Post: December 18th, 2003, 08:29 AM

IMN logo majestic logo threadwatch logo seochat tools logo