On a spanking new installation of a linuxppc distribution, I've been able to compile mySQL and PHP, and then recompile apache. So everything is running happy.

However, I wanted to also install the PDFLib. According to the 3.0.14 release notes as well as the PDFLib site, the pdf libraries should already be installed with PHP. However, none of the functions work (I get a "fatal error", call to undefined function type of error).

I've tried downloading the PDFLib tarball and doing a recompile of php with the --with-pdf tag set to the pdflib directory, and then recompiled apache, but to no avail.

Does anyone know what's up? What am I doing wrong?

(on a side note, does anyone know how to UNinstall the old apache that came with teh linuxppc distribution? I basically installed the new apache in another directory, and my httpd starts up the PHPized Apache server -- but it'd be nice to get rid of the old unPHPized apache server...)