I'm currently using Redhat 5.2 with Redhat Secure Web Server 2.0. When I was installing PHP 3.0.15 during the make phase, I encountered the following error. Can anyone please advise?

Error message encountered:

apxs:Error: Unknown option: W
Usage: apxs -g -n <modname>
apxs -q <query> ...
apxs -c [-o <dsofile>] [-D <name>[=<value>]] [-I <incdir>]
[-L <libdir>] [-l <libname>] <files> ...
apxs -i [-a] [-n <modname>] <dsofile> ...
make: *** [libphp3.so] Error 1