#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2012
    Posts
    3
    Rep Power
    0

    Question Mac OS: localhost/wordpress/wp-login.php, login Error 401


    Hi- I have searched Google, and also the Dev Shed forum for a solution to no avail. Maybe this post will help someone in the same situation. Here's my setup:

    Remote server side=
    Linux-hosted, WP 3.4.2 site with these plugins...

    - Akismet

    - Duplicator

    - HTTP Authentication

    - Role Scoper

    - WordPress Importer

    I can log into the remote site without a hitch via WP admin account.

    Now on localhost:
    I used the Duplicator plugin to download a full WP copy on a MacBook 10.6.8 laptop running XAMPP 1.7.3.

    HTTP Authentication plugin has been moved out of my localhost install.

    If I do one of these two things the error 401 (below) appears on Chrome, Safari, and Firefox:

    -update my permalinks using duplicator by accessing http://localhost/wordpress/wp-admin/options-permalink.php

    -and/or log into the localhost site, which seems to work at first with my remote-site admin account but quickly errors out by accessing
    http://localhost/wordpress/wp-admin/

    Result is this error on all browsers, with saved passwords cleared:
    Authentication required!

    This server could not verify that you are authorized to access the URL "/wordpress/wp-admin/". You either supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.

    In case you are allowed to request the document, please check your user-id and password and try again.

    If you think this is a server error, please contact the webmaster.
    Error 401

    Thanks in advance!
    Tom
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2012
    Posts
    3
    Rep Power
    0
    This error was caused by a faulty .htaccess file in the [web root]/wordpress/wp-admin/ directory.

    Duplicator did not change this from my remote site, I manually edited the .htaccess file to read:
    AuthName "WordPress"
    AuthType Basic

    Problem solved.

IMN logo majestic logo threadwatch logo seochat tools logo