#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2000
    Location
    Caracas, Venezuela
    Posts
    5
    Rep Power
    0
    I am running mysqld-shareware for NT 4.0 but cannot seem to get the machine to work with PHP and mySQL.

    When I try to access a mySQL database I get the following error, "Fatal error:
    Call to unsupported or undefined function mysql_connect() in conexion.php3
    on line 8".

    I am going CRAZY with this and I am sure it must be a configuration problem, I have uncommented the line to load the module php3_mysql.dll in the file php3.ini which is located in the c:winnt directory. Also this dll is located in the chp3 directory.

    What else can I configure? Any help will be appreciated, thanks in advance.

    Sandra
  2. #2
  3. No Profile Picture
    Apprentice Deity
    Devshed Loyal (3000 - 3499 posts)

    Join Date
    Jul 1999
    Location
    Niagara Falls (On the wrong side of the gorge)
    Posts
    3,237
    Rep Power
    18
    2 things:

    1. Did you set the directory for your php3_.dll files in the .ini? (Can't remember now what that's called.)

    2. What version of php are you running? I've heard some problems with 3.0.13 (and maybe 12) with the Win32 versions and mysql. Haven't experienced it myself since I just moved from 3.0.9 to 3.0.14 but I know others have fixed it by changing from 12 or 13 to 11 or 14

    Hope this helps
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2000
    Location
    Calcutta, West Bengal, India
    Posts
    25
    Rep Power
    0
    I am sorry, cant give a solution but seem to hv the same problem on Linux.

    I am using php-3.0.12 on Linux with apache and Mysql, and I seem to face this very same problem
    - unsupported or undefined function mysql_connect().

    The PHP was installd from the Red Had dist RPM.
    Can I solve this or do I hv to download PHP-3.0.14 ? In tht case how do I install the tar file on my Linux Server.

    Thanx for any help on this.
  6. #4
  7. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2000
    Location
    Caracas, Venezuela
    Posts
    5
    Rep Power
    0
    <BLOCKQUOTE><font size="1" face="Verdana,Arial,Helvetica">quote:</font><HR>Originally posted by rod k:
    2 things:

    1. Did you set the directory for your php3_.dll files in the .ini? (Can't remember now what that's called.)

    2. What version of php are you running? I've heard some problems with 3.0.13 (and maybe 12) with the Win32 versions and mysql. Haven't experienced it myself since I just moved from 3.0.9 to 3.0.14 but I know others have fixed it by changing from 12 or 13 to 11 or 14

    Hope this helps
    [/quote]

    Thank you, thank you, thank you! In fact I checked and I had installed PHP version 3.0.13, I downloaded 3.0.14, installed it, and the message disappeared! Voila!
    I never would have figured that out without your help, thanks again.... Sandra

Similar Threads

  1. Replies: 2
    Last Post: August 18th, 2004, 10:45 PM
  2. How to see the Memory used by a PHP script?
    By Pardall in forum PHP Development
    Replies: 4
    Last Post: February 13th, 2004, 03:54 PM
  3. PHP with UnixODBC
    By coder4hire in forum PHP Development
    Replies: 2
    Last Post: January 20th, 2004, 01:14 PM
  4. Passing string from PHP to Javascript
    By ka8oad in forum JavaScript Development
    Replies: 4
    Last Post: January 17th, 2004, 03:12 PM
  5. UnixODBC + PHP + Apache + Empress
    By coder4hire in forum Database Management
    Replies: 0
    Last Post: January 15th, 2004, 01:41 PM

IMN logo majestic logo threadwatch logo seochat tools logo