#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2000
    Location
    Boston, MA
    Posts
    54
    Rep Power
    15
    Hello to all and thank-Q for reding
    i have the following problem with netscape
    when i search for data in MySQL and then create a link of the data returned to another
    page so users can click on the link and then edit the data associated with their selection,
    thats were Netscape fails to pass the data to the next page so when users click on the links nothing comes up except if they are using IE 4.0+ which passes the data with no plroblem...
    any ideas anybody?
    i already tried the forms in HTML and PHP but wiht no success...
    if you would like to see the code i'll be more than glad to post it or e-mail it to you thankx for taking the time to read...

    MIke (eduany)
  2. #2
  3. Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Feb 2000
    Location
    Perth West Australia
    Posts
    757
    Rep Power
    15
    If you have <a href="#.php3?string=this is a string"> Netscape will only return -this-, goto the php manual and look up string urlencode() and urldedode() this places % between spaces so NS gets the idea.

    Simon

    ------------------
    Simon Wheeler
    FirePages -DHTML/PHP/MySQL
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2000
    Location
    Boston, MA
    Posts
    54
    Rep Power
    15
    Thank_Q for your reply firepages..
    i tried the 'urlencode()' like this:
    (but wiht no success)


    while ($r = mysql_fetch_array($query)) {
    $alias = $r["alias"];
    $s_type = $r["s_type"];
    $rack = $r["rack"];
    $rack_p = $r["rack_p"];
    $s_port = $r["s_port"];
    $os = $r["os"];
    $ip_add = $r["ip_add"];

    echo "<tr>
    <td align=left>
    <a href="editing.php3?alias=urlencode($alias)&s_type=urlencode($s_type)&etc...

    // and here is what the other file looks like:

    <html>
    <body bgcolor=#ffffff>

    <img src="img/hnet.gif" alt=""><h1>Edit entry</h1>
    <form method="get" action="editdb.php3">

    <table width="700" align=center bgcolor=gray border=1 cellspacing=0 cellpadding=0>

    <tr>
    <td bgcolor=#6666cc width="25%"><b>Name/Alias:</b></td><td><font color=orange size=+1><b><?php echo "$alias";?></b></font></td></tr>

    <tr>
    <td bgcolor=#6666cc width="25%"><b>Server_Type:</b></td><td><input type=text name=s_type size=20 maxlength=20 value="<?php echo "$s_type";?>"></td></tr>
    etc......

    thank-Q all

    eduany (php/mysql newbie)

    [This message has been edited by eduany (edited April 24, 2000).]

    [This message has been edited by eduany (edited April 24, 2000).]
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2000
    Location
    Ontario, Canada
    Posts
    498
    Rep Power
    18
    Don't include the functions (urlencode/urldecode) inside the echo statement. That just echoes urlencode() with the string evaluated in it. Instead, set temporary variables that hold the url-encoded string.

    Try this (rename the vars of course):

    $str_tmp = urlencode($this);
    echo "<a href="editing.php3?alias=$str_tmp ...">yadda</A>


    ------------------
    To alcohol! The cause of, and solution to, all of life's problems. -- Homer Simpson
  8. #5
  9. No Profile Picture
    Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2000
    Location
    thane
    Posts
    50
    Rep Power
    0
    I'm a new member sir

    but i was having the same problem

    wht i did (becuz at that time i was not aware of urlencode())
    like
    <a href="editing.php3?address="$address"....>xyz</a>

    same thing worked for me
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2000
    Location
    Boston, MA
    Posts
    54
    Rep Power
    15
    Thank-Q CKA...
    appreciate your help, as you can see i am pretty new to this language, only newbies like me makes these type of mistakes..

    once again thank-Q to all for writing...
    until next time Folks!

    ps: i like the quoted.. lol

    [This message has been edited by eduany (edited April 29, 2000).]
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2000
    Location
    Ontario, Canada
    Posts
    498
    Rep Power
    18
    Seems to me that you're setting the URL-encoded variables before you're setting the regular ones. Therefore, the urlencoded variables will be null, and you won't have your script anywhere near working.

    ------------------
    To alcohol! The cause of, and solution to, all of life's problems. -- Homer Simpson
  14. #8
  15. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2000
    Location
    Boston, MA
    Posts
    54
    Rep Power
    15
    Hello im back....
    i finally go this working
    have to admit i learned a lot from this one...

    thank-Q guys

    Mike (eduany)

IMN logo majestic logo threadwatch logo seochat tools logo