Hello All,

I have a situation which I can't for the life of me figure out.

I've got a form and PHP (below) script which work perfectly on my Windows 95 local sistem,
but when I load them to my UNIX server, it fails to recognize the uploaded images (foto[]) as defined by the oficial PHP literature.

The following is the form I'm using to upload the photos:
==================
<form method="post" action="insertar_casa.php3" enctype="multipart/form-data">
<input type="text" name="text_foto[]" size="25" maxlength="25">
<input type="file" name="foto[]">
<input type="text" name="text_foto[]" size="25" maxlength="25">
<input type="file" name="foto[]">
....
<input type="text" name="text_foto[]" size="25" maxlength="25">
<input type="file" name="foto[]">
<input type="submit" name="Submit" value="Ingresar Datos">
==================

They are submitte to the following PHP script:

==================

<?php

/* Set database variables */
/* For server upload, insert the variables in comments */

$host = "localhost";
$username = "myusername";
$password = "mypassword";
$dbName = "mydatabase";
$foto_cuantity = 0;

/* Get the amount of photos submitted */

for ($j=0; $j < 12; $j++) {
if ($foto_size[$j] != 0){
$foto_cuantity++;
$k = $j + 1;
print "The name of file number $k is $foto_name[$j].<p>";
}
}

print "The amount of photos you submitted is $foto_cuantity.<p>";

?>
==================

Does anyone have any idea why this works on Win95 but not on the UNIX server?

Thank you very much if you have any ideas!!

Bryan



------------------