#1
  1. No Profile Picture
    jacky
    Guest
    Devshed Newbie (0 - 499 posts)
    Hi,
    I am trying to setup a http server with database support and I use:
    apache 1.3.9, mysql 3.22.25, php 3.0.12 and Redhat 6.0.

    I install the components in the following sequence:
    1) I install mysql with:
    ./configure --prefix=/usr/mysql3.22.25
    --with-client-ldflags=-all-static
    --with-mysqld-ldflags=-all-static
    --with-charset=big5

    make
    make install
    scripts/mysql_install_db
    (I got mysql up and running

    2) I un-tar apache and
    ./configure --prefix=/usr/apache1.3.9

    3) I un-tar php and install it as:
    ./configure
    --with-shared-apache=/home/admin007/software/apache/apache_1.3.9/
    --with-mysql=/usr/mysql3.22.25/

    make
    make install
    (no errer message

    4) I install apache as:
    ./configure --prefix=/usr/apache1.3.9
    --enable-module=most
    --enable-shared=max
    --activate-module=src/modules/php3/libphp3.a
    --enable-shared=php3
    --enable-suexec
    --suexec-caller=nobody
    --suexec-docroot=/home
    --suexec-uidmin=500
    --suexec-gidmin=500
    --suexec-safepath="/bin:/usr/bin:/usr/local/bin"

    ( no error message
    ( so, I type make to complie apache and I got a error message
    -----------------------------------------------------------
    gcc -rpath /usr/mysql3.22.25//lib/mysql -shared -o libproxy.so mod_proxy.lo
    proxy_cache.lo proxy_con
    nect.lo proxy_ftp.lo proxy_http.lo proxy_util.lo
    gcc: unrecognized option `-rpath'
    /usr/mysql3.22.25//lib/mysql: file not recognized: Is a directory collect2: ld returned 1 exit status
    make[4]: *** [libproxy.so] Error 1
    make[3]: *** [all] Error 1
    make[2]: *** [subdirs] Error 1
    make[2]: Leaving directory `/home/admin007/software/apache/apache_1.3.9/src'
    make[1]: *** [build-std] Error 2
    make[1]: Leaving directory `/home/admin007/software/apache/apache_1.3.9'
    make: *** [build] Error 2

    Any ideas??
    Thanks!

    Jacky
  2. #2
  3. No Profile Picture
    jasonw
    Guest
    Devshed Newbie (0 - 499 posts)
    Jacky,
    Hey it looks like when you compiled php you ut some extra slashes in when you specified the mysql directory. If you notice you put --with-mysql=/usr/mysql3.22.25/ instead of --with-mysql=/usr/mysql3.22.25
    this extra slash will make a difference. When you go to compile apache it will look for the mysql libraries in /usr/mysql3.22.25//lib/mysql
    I had the same problem when I first tried to install php and mysql.

    ------------------
    Jason Woods
    http://www.bon-fire.com
    jasonw@bon-fire.com
    ------------------

    [This message has been edited by jasonw (edited 09-21-99).]

    [This message has been edited by jasonw (edited 09-21-99).]
  4. #3
  5. No Profile Picture
    jacky
    Guest
    Devshed Newbie (0 - 499 posts)
    Hi Jason,

    I remove the slash and try to complie them again, but it complain about the -rpath option of gcc.
    Any ideas?

    Jacky

Similar Threads

  1. Mysql problem.
    By Nik in forum MySQL Help
    Replies: 54
    Last Post: December 21st, 2006, 06:02 PM
  2. Starting MySQL
    By bwreath in forum MySQL Help
    Replies: 1
    Last Post: January 20th, 2004, 11:17 PM
  3. installing apache, php and mysql
    By lucilue2003 in forum PHP Development
    Replies: 9
    Last Post: January 8th, 2004, 09:18 AM
  4. Replies: 3
    Last Post: December 25th, 2003, 05:16 AM

IMN logo majestic logo threadwatch logo seochat tools logo