#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2000
    Posts
    1
    Rep Power
    0
    I am attempting to install an apache web server using both mysql and sybase ASE. I can configure everything up until I attempt to use both PHP3 and PHP4 under apache. I can set up apache to run as a standard server, but when I attempt to compile it with both of them it flips out. something about multiple defintion and size of symbol. I'll send a list of all the commands I used.

    cd /tmp/extract
    tar -zxvf ../apache-1.3.14.tar.gz
    cd apache-1.3.14
    ./configure
    --with-prefix=/home/www
    --enable-rule=SHARED_CORE
    --enable-module=so
    make
    make install

    cd /tmp/extract
    tar -zxvf ../php-3.0.17.tar.gz
    cd php-3.0.17
    ./configure
    --enable-versioning
    --with-mysql=/opt/mysql
    --with-sybase=/opt/sybase-11.9.2
    --with-apache=../apache-1.3.14
    --with-xml
    --enable-track-vars
    make
    make install
    cp php3.ini-dist /usr/local/lib/php3.ini

    cd /tmp/extract
    tar -zxvf ../php-4.0.3pl1.tar.gz
    cd php-4.0.3pl1
    ./configure
    --enable-versioning
    --with-mysql=/opt/mysql
    --with-sybase=/opt/sybase-11.9.2
    --with-apache=../apache-1.3.14
    --with-xml
    --enable-track-vars
    make
    make install
    cp php.ini-dist /usr/local/lib/php.ini

    cd /tmp/extract/apache-1.3.14
    ./configure
    --with-prefix=/home/www
    --enable-rule=SHARED_CORE
    --enable-module=so
    --activate-module=src/modules/php3/libphp3.a
    --enable-module=php3
    --activate-module=src/modules/php4/libphp4.a
    --enable-module=php4
    make

    as soon as I attempt to make it at this point, I get the error message. If anyone knows how I can go ahead and get these running, I would be forever in debt.

    Thanks
  2. #2
  3. No Profile Picture
    freebsd
    Guest
    Devshed Newbie (0 - 499 posts)
    If you enable DSO support, don't use --with-apache, use --with-apxs=/path/to/apxs instead.
    --with-prefix=/home/www, it should be "prefix=/path/to". BTW, your prefix shouldn't be /home/www, make it datadir is more reasonable.
    Also, placing your tarball in /tmp directory is extremely BAD idea, use /usr/local/src instead.
    You don't need to compile your apache twice.
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2000
    Posts
    1
    Rep Power
    0
    So I went ahead and followed your advice, and used apxs instead, but added another variable (I know I can be a pain in the a$$ sometimes). I can compile everything up until I add another module after apache is installed. so here's the commands and notes I used.

    cd /opt
    mkdir extract
    cd extract
    tar -zxvf /tarz/apache-1.3.14.tar.gz
    cd apache.1.3.14
    ./configure
    --prefix=/usr
    --enable-rule=SHARED_CORE
    --enable-module=so

    cd /opt/extract
    tar -zxvf /tarz/mod_perl-1.24_01.tar.gz
    cd /opt/extract/mod_perl-1.24_01
    perl Makefile.PL
    APACHE_SRC=../apache_1.3.14/src
    DO_HTTPD=1
    USE_APACI=1
    PREP_HTTPD=1
    EVERYTHING=1
    make
    make test
    make install


    SSL Install

    RSA Libraries
    cd /opt/extract
    tar -zxvf /tarz/rsaref-2.0.tar.gz
    cd rsaref-2.0
    cp -rp install/unix local
    cd local
    make
    mv rsaref.a librsaref.a

    OpenSSL
    cd /opt/extract
    tar -zxvf /tarz/openssl-0.9.6.tar.gz
    cd openssl-0.9.6
    ./config --prefix=/usr
    -L`pwd`/../rsaref-2.0/local/rsaref -fPIC
    make
    make test
    make install

    Mod_SSL
    tar -zxvf mod_ssl-2.7.0-1.3.14.tar.gz
    cd mod_ssl-2.7.0-1.3.14
    ./configure --with-apache=../apache_1.3.14

    cd apache_1.3.14
    SSL_BASE=../openssl-0.9.6
    RSA_BASE=../rsaref-2.0/local
    ./configure
    --prefix=/usr
    --enable-rule=SHARED_CORE
    --enable-module=so
    --enable-module=ssl
    --enable-shared=ssl
    --activate-module=src/modules/perl/libperl.a
    --enable-module=perl
    make
    make certificate
    make install

    MAKE SURE APACHE IS NOT RUNNING!!!!!!!

    PHP3 and PHP4 installation
    (php3)
    cd /opt/extract
    tar -zxvf /tarz/php-3.0.17.tar.gz
    cd php-3.0.17
    ./configure
    --enable-versioning
    --with-mysql=/usr
    --with-interbase=/opt/interbase
    --with-apxs=/usr/bin/apxs
    --enable-track-vars
    make
    make install
    cp php3.ini-dist /usr/local/lib/php3.ini

    (php4)
    ./configure
    --enable-versioning
    --with-mysql=/usr
    --with-interbase=/opt/interbase
    --with-apxs=/usr/bin/apxs
    --with-xml
    --enable-track-vars
    cp php.ini-dist /usr/local/lib/php.ini

    And as of this point, when I run 'apacectl configtest', I get the following error.
    "Syntax error on line 239 of /usr/conf/httpd.conf:
    Cannot add module via name 'mod_php3.c': not in list of loaded modules"

    Did I do something else wrong? I want to be able to get all of this running smoothly, and not have to worry.
    I swear when I get all of this running, I will write a walkthrough so nobody else will go through the hell I have.

    Thanks for the help
  6. #4
  7. No Profile Picture
    freebsd
    Guest
    Devshed Newbie (0 - 499 posts)
    >>Cannot add module via name 'mod_php3.c': not in list of loaded modules"

    Assuming your libphp3.so and libphp4.so reside in /usr/libexec/apache/ (default based on your defined PREFIX)

    Then do you have this line in your httpd.conf?

    LoadModule php3_module libexec/apache/libphp3.so
  8. #5
  9. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2000
    Posts
    1
    Rep Power
    0
    In my httpd.conf

    "LoadModule ssl_module libexec/libssl.so
    LoadModule php3_module libexec/libphp3.so
    LoadModule php4_module libexec/libphp4.so"

    From what I can tell, the SSL loads fine, but php3 will not go. I'm not sure if it gets as far as php4, but the lines for the so's are there.
    Any other suggestions?

    Thanks Again

    BTW... apache is installed in /usr
  10. #6
  11. No Profile Picture
    freebsd
    Guest
    Devshed Newbie (0 - 499 posts)
    The problem could be the mixing of static builds and DSO. You should pick either one, but not both.

    You built mod_ssl statically so "LoadModule ssl_module libexec/libssl.so" shouldn't be in your httpd.conf. If you added that in manually, try to remove it and "apachectl graceful". To debug the problem, I would uncomment the LoadModule lines of php3 and php4 and modssl as well as the AddModule lines. Then test mod_perl in the first place and make sure it's running.

Similar Threads

  1. Apache 2.0 and PHP4 Upgrade Problems
    By xml in forum PHP Development
    Replies: 4
    Last Post: February 10th, 2004, 12:52 PM

IMN logo majestic logo threadwatch logo seochat tools logo