#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Posts
    34
    Rep Power
    15
    Hi,
    I just swapped all my .php3 files to .php4,
    and there seems to be an odd error. When passing variables via the URL, PHP4's version
    of rawurldecode seems to convert all %27's
    to ' rather than just ' (which is what PHP3
    did fine).

    Any ideas? Is it just me, my setup of PHP4
    or am I missing something obvious?

    Thnx
    enigmatrix
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2000
    Location
    Ontario, Canada
    Posts
    498
    Rep Power
    18
    Could be a bug... Simple fix for that: use a StripSlashes() around the rawurldecode() function. :P

    ------------------
    To alcohol! The cause of, and solution to, all of life's problems. -- Homer Simpson
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Posts
    34
    Rep Power
    15
    Thanks for that....
    I get so bogged down in trying to solve
    the bug that I forget work-arounds.

    Cheers,
    enigmatrix
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Posts
    32
    Rep Power
    15
    It's not a bug - you just didn't have magic quotes enabled before and now you do. Better to just disable them than use stripslashes() all the time...
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Posts
    34
    Rep Power
    15
    Sorry - what are magic quotes?
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Posts
    34
    Rep Power
    15
    Ah - ignore that - I've got it!
    :-)

Similar Threads

  1. IE positioning bug and its solution
    By delerious in forum HTML Programming
    Replies: 3
    Last Post: December 23rd, 2003, 05:42 AM
  2. Replies: 1
    Last Post: September 24th, 2003, 10:20 AM
  3. Apache2 w/ php4 as DSO.. but I need to revert to php3
    By JunkCookie in forum PHP Development
    Replies: 0
    Last Post: August 11th, 2003, 03:05 PM
  4. Very strange bug, vars ignored.
    By Kristten in forum PHP Development
    Replies: 7
    Last Post: June 25th, 2003, 01:26 PM
  5. PostgreSQL encrypted password bug?
    By kernshen in forum PostgreSQL Help
    Replies: 1
    Last Post: March 28th, 2002, 03:08 AM

IMN logo majestic logo threadwatch logo seochat tools logo