#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2000
    Location
    San Diego, CA, USA
    Posts
    8
    Rep Power
    0
    I changed the php.ini file. I am under the impression that I need to re-start apache. I've tried stopping then starting apache. I've also tried just restarting it. These commands seem to be working, but the changes I make to the php.ini file are not put into effect and do not show up when I call phpinfo(). Anyone have any ideas how I can get my new php.ini recognized?

    to stop it:
    kill -TERM `cat /var/run/httpd.pid`

    to restart:
    kill -HUP `cat /var/run/httpd.pid`

    to start it:
    /usr/local/apache/bin/apachectl start

  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2000
    Location
    Ontario, Canada
    Posts
    498
    Rep Power
    18
    Is the HTML for the phpinfo() in your cache? Try a hard reload (ctrl+f5 in Internet Explorer, some other combo in netscape). If that doesn't work, then php isn't recognizing your modified settings.

    ------------------
    To alcohol! The cause of, and solution to, all of life's problems. -- Homer Simpson
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2000
    Location
    San Diego, CA, USA
    Posts
    8
    Rep Power
    0
    I tried the hard reload, and it did not work.
    Any ideas on why my modified settings are not recognized?
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2000
    Location
    London/UK
    Posts
    91
    Rep Power
    14
    Might be a silly question but are you editing the correct php.ini?

    do phpinfo() and check where php thinks that php.ini is

    usually /usr/lib/php.ini

    ??

    ------------------
    http://back-end.org
  8. #5
  9. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2000
    Location
    San Diego, CA, USA
    Posts
    8
    Rep Power
    0
    Thanks, but it's in the right place.
    (/usr/local/lib for me)

Similar Threads

  1. starting apache under linux
    By wannabe in forum Beginner Programming
    Replies: 15
    Last Post: February 4th, 2004, 06:27 PM
  2. PHP -> system commands
    By Tantalus in forum PHP Development
    Replies: 1
    Last Post: January 28th, 2004, 10:51 AM
  3. Apache 2 not starting (winxp)
    By thegingerbloke in forum Apache Development
    Replies: 7
    Last Post: December 21st, 2003, 05:09 PM
  4. uh.. xitami and apache help plz!!!
    By nitrogencool in forum Apache Development
    Replies: 1
    Last Post: December 8th, 2003, 07:02 PM
  5. php.ini changes not taking hold
    By JunkCookie in forum PHP Development
    Replies: 2
    Last Post: October 23rd, 2003, 01:21 PM

IMN logo majestic logo threadwatch logo seochat tools logo