#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2000
    Posts
    29
    Rep Power
    0
    I'm including my code below. Whenever i click on the "next" link it laggs and never seems to change the page or connect when passing teh variable...

    It's a simple page that i'm using to debug another bigger page but i can't seem to figure out what the problem is. I'm on win98/php4rc2/apache 1.3.9. Every other php works... Actually the other page where i have simliar code(as far as reading a directory) works too so i'm lost? :/

    any help would be appreciated

    -cisk

    -------
    <?
    $PHP_SELF = getenv("PHP_SELF");
    $picPath = "C:WINDOWSDesktopwebpagesdjcisktry1piximagesgirls";
    $d = dir($picPath);
    $imgs = array();
    $numImgs = 0;
    while($file = $d->read()) {
    if($file[0] != "." && eregi(".jpg$|.gif$|.png$", $file)) {
    $imgs[$numImgs] = $file;
    $numImgs++;
    }
    }

    /* find previous place */
    if(!isset($imgPlace) &#0124; &#0124; $imgPlace = "")
    $imgPlace = 0;

    ?>
    <html>
    <head>
    <title>Picture viewer</title>
    <body>

    <?
    /* display links */
    $counter = 1;
    for($i = $imgPlace; $i < $numImgs; $i++) {
    if($counter <= 10) {
    printf("%d. <a href="%s%s">%s</a>n<br>n", $i+1, $picPath, $imgs[$i], $imgs[$i]);
    $counter++;
    }
    }
    $oldPlace = $imgPlace;
    $imgPlace = $counter;

    printf("<br>Counter: %d<br>nn", $counter);

    if(!$oldPlace == 0) {
    printf("<a href="%s?imgPlace=%s">back</a>n", $PHP_SELF,$oldPlace);
    }
    printf("<a href="%s?imgPlace=%s">next</a>n", $PHP_SELF, $imgPlace);

    $d->close();
    ?>
    </body>
    </html>

  2. #2
  3. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2000
    Posts
    29
    Rep Power
    0
    i fixed it never mind

Similar Threads

  1. computer stops responding after loading
    By crackerweb in forum Windows Help
    Replies: 0
    Last Post: January 30th, 2004, 12:26 PM
  2. print jobs just queueing printer not responding
    By gmakandidze in forum UNIX Help
    Replies: 0
    Last Post: December 31st, 2003, 04:59 AM
  3. wxPerl refresh / not responding
    By DasNoc in forum Perl Programming
    Replies: 0
    Last Post: November 10th, 2003, 12:11 PM
  4. Apache not responding to PHP-scripts
    By Debian-Apache in forum Apache Development
    Replies: 1
    Last Post: November 9th, 2002, 01:20 AM
  5. apache not responding...
    By hjohns in forum Apache Development
    Replies: 3
    Last Post: October 23rd, 2002, 08:09 PM

IMN logo majestic logo threadwatch logo seochat tools logo