#1
  1. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Sep 2003
    Posts
    506
    Rep Power
    15

    session problems


    for some reason I cannot start a session. After being thrown tonned of errors I commented out the code so that only
    session_start();
    exists, but I still get errors

    This is the first error:

    Warning: session_start(): open(/tmp\sess_17db58ee9cba05193670363033e8d331, O_RDWR) failed: No such file or directory (2)

    I also get a lot of errors says that "heade is alredy sent" don't know about this oe either.

    I am a little lost so if someone could help me out I would appreciate it
    Last edited by iso; October 29th, 2003 at 02:33 PM.
  2. #2
  3. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Posts
    4
    Rep Power
    0
    Take a look at session.save_path in your php.ini.

    Or use,

    session_save_path() to change the location that session files are saved in.
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Sep 2003
    Posts
    506
    Rep Power
    15
    thanks. I tried to manually set the path, but it would always throw the same error. I then used the method and it worked beautifully. Thanks again
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Sep 2003
    Posts
    506
    Rep Power
    15
    i have changed all the php.ini files that I could find so that I don't have to call the function all the time, but even though I have changed them all it still shows the /tmp folder as being where it is looking.

    I also just renamed all the php.ini files but the when I try to access the page it still throws the same error

    Does anyone have any insight on the solution to this one?
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2003
    Posts
    70
    Rep Power
    15
    I had what sounds like a similar problem..

    Take a look at the results of phpinfo() more specifically, look at the value for "Configuration File (php.ini) Path" and go make sure the php.ini file is actually there...

    One of the servers I work on didn't have a php.ini file at that location so any changes I made to /etc/php.ini didn't do anything... moving the file to the location stated in that field fixed it for me.
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Sep 2003
    Posts
    506
    Rep Power
    15
    Ya that is what seems to be the problem. The config path is C:/Windows , but there is no php.ini file there.

    The way that I have things set up now using the session_save_path() it works, but it would be nice to fix it and also so if there are other settings that I want to change I can.

    For example I have to change the lifetime of the session objects, but...Iam sure there is a method to do that as well, so no biggie.
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Sep 2003
    Posts
    506
    Rep Power
    15
    I put a php.ini file into the C:/Windows dir, but after checking the settings it still shows the previous path for the session objects to be stored, when I changed then on the php.ini file that I put in the windows dir.

    So how does a person change the configuration path? say to C:/php instead of the windows path.

    Also for some reason my session objects don't kick the bucket after the set 1440 seconds limit that seems to be specified (I am assuming that is 1440 seconds). Any reasons for this?

    Thanks

IMN logo majestic logo threadwatch logo seochat tools logo