#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2013
    Posts
    1
    Rep Power
    0

    Smile Smtp_port setting in php.ini


    Hi all,

    i'm using XAMPP.1.7.7 server to test my php file and i'm having the following error while testing a php file. Can someone tell me how to configure "SMTP" and "smtp_port" setting in php.ini or use ini_set()

    Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\xampp\htdocs\TestsPHP\Chap4\RE4-2-ContactForm.php on line 115

    Thanks.
  2. #2
  3. --
    Devshed Expert (3500 - 3999 posts)

    Join Date
    Jul 2012
    Posts
    3,904
    Rep Power
    1045
    Hi,

    you need a mailserver to send mails.

    Simply use the one provided by XAMPP (Mercury). You need to configure a few things and then start the server in the XAMPP control panel.

IMN logo majestic logo threadwatch logo seochat tools logo