#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2000
    Location
    Netherlands
    Posts
    32
    Rep Power
    15
    Who can help me out with the following problem:

    I installed Apache 1.3.9 and PHP3 on local W98. So far so good.
    Then I load my PHP-form-file locally at http://127.0.0.1/preken/, I push a formbutton to generate dynamically some info and then... the next 'page' loaded in the browser is: http://127.0.0.1/php3/php.exe/preken...rs+&versie=NL.
    Which should be: http://127.0.0.1/preken/index.html?g...rs+&versie=NL.

    You can see in the address the 'php3/php.exe/'-part, which should not be there. It makes the browser not loading the right images for that page.

    What goes wrong (in the configuration)?

    Thanks,
    Richard Vos

  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 1999
    Location
    California
    Posts
    43
    Rep Power
    15
    Hi Richard,

    According your name and the language you are using you are dutch too.

    Please send me an email with your code at vdschoor@il.fontys.nl and I'll try to help you out.

    Iwan van der Schoor
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 1999
    Location
    California
    Posts
    43
    Rep Power
    15
    Richard,

    I couldn't reply on your email, because your emailadres didn't work.
    This is the possible solution :

    remove the following line from your httpd.conf file :
    Action application/x-httpd-php3 "/php3/php.exe"

    I think the way you used this line is incorrect, but I am not sure about this.
    What I understood from the comments in the httpd.conf file is that this is used so you don't have to type full path-names when you are using certain kinds of files.
    For example :
    The page with the calling form is located in /web/username/sub/directory/page.html
    And all your php scripts are in the directory /web/username/php
    Then you use this line to tell the webserver to look for the php script in this directory.

    I hope this is the right explanation, if not then I hope others will explain it better.
    Anyway, removing the line will probably solve it.

    Iwan van der Schoor


  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2000
    Location
    Netherlands
    Posts
    32
    Rep Power
    15
    Sorry to say this, but removing this line
    Action application/x-httpd-php3 "/php3/php.exe"
    from the httpd.conf file, will disable the php3-module.
    With the above the problem AND php3 will not show up again ;-)

    Who can help me out...?

    Richard Vos
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 1999
    Location
    SLC, UT, USA
    Posts
    47
    Rep Power
    15
    Perhaps a mime type setting in the webserver software?

Similar Threads

  1. loading a jsp page to a table cell
    By shashike in forum Java Help
    Replies: 0
    Last Post: February 8th, 2004, 09:51 PM
  2. page gets mixed up on loading
    By webtekie in forum Apache Development
    Replies: 1
    Last Post: February 4th, 2004, 04:07 PM
  3. strange problem with apache not running scripts
    By rjstephens in forum Apache Development
    Replies: 0
    Last Post: January 23rd, 2004, 07:38 AM
  4. asp loading page
    By bignik in forum ASP Programming
    Replies: 4
    Last Post: January 18th, 2004, 03:24 PM
  5. page is loading please wait - like devshed search!
    By bignik in forum PHP Development
    Replies: 1
    Last Post: January 17th, 2004, 02:55 PM

IMN logo majestic logo threadwatch logo seochat tools logo