#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2012
    Posts
    153
    Rep Power
    13

    Website on wamp issues


    Hi

    I am building a website on wamp that I can play around with and have got some errors

    They are

    SCREAM: Error suppression ignored for
    ( ! ) Notice: Undefined index: qs in C:\wamp\www\admin website\admin\index.php on line 22

    AND

    SCREAM: Error suppression ignored for
    ( ! ) Notice: Undefined index: inv_usr in C:\wamp\www\admin website\admin\index.php on line 52

    ON LINE 22 IS THE FOLLOWING

    if($_REQUEST["qs"]=="logout"

    AND ON LINE 52 IS THE FOLLOWING

    <?php if($_GET['inv_usr'] == 'yes')

    I got a couple on the front end of the website as well but will worry about them after

    Any ideas

    Kind regards

    Ian
  2. #2
  3. No Profile Picture
    Lost in code
    Devshed Supreme Being (6500+ posts)

    Join Date
    Dec 2004
    Posts
    8,317
    Rep Power
    7170
    When you attempt to use an array index that might not exist, such as anything in $_GET, $_POST, $_COOKIE, etc. You need to check whether it exists before using it using either isset() or empty().
    PHP Code:
    if(isset($_REQUEST["qs"]) && $_REQUEST["qs"]=="logout" 
    PHP FAQ

    Originally Posted by Spad
    Ah USB, the only rectangular connector where you have to make 3 attempts before you get it the right way around

IMN logo majestic logo threadwatch logo seochat tools logo