1. No Profile Picture
    Devshed Newbie (0 - 499 posts)
    Details: I recently setup Apache 1.3.6, PHP3.0.9 for RedHat5.2 Linux2.0.32 kerner
    successfully. But when I point Lynx to the http://localhost/test.php3 it prompts me to save the file.

    I have rechecked all the changes requested to made in the httpd.conf doc, and still I have no clue. This has happened the same when I point my Netscape browser to the test.php3.

    Please help........
  2. #2
  3. No Profile Picture
    Devshed Newbie (0 - 499 posts)
    Sounds like that the server is not running the php interpreter when a request for a filename.php3 is made.

    Check the "Setting Up Database Driven Websites" article in DevShed.com. It has a section on installing PHP.


    Hope this helps.

  4. #3
  5. No Profile Picture
    Devshed Newbie (0 - 499 posts)

    Make sure in your httpd.conf file that you have told apache to
    properly parse all files ending in php3. This is done by doing the

    AddType application/x-httpd-php3 .php3
    AddType application/x-httpd-php3-source .phps

    Jason Woods

  6. #4
  7. No Profile Picture
    Devshed Newbie (0 - 499 posts)
    I have gone through the "Database Driven Website" several times, infact I started from there.

    Also I set the AddTypw application/x-httpd-php3 ......
    in the /etc/httpd/httpd.conf (I made sure ther is only one httpd.conf in my box

    What bothers me the FAQ in PHP3 4.8, It says
    I should see mod_php3.c if I do a /usr/local/apache/bin/httpd -l
    In my system it shows only http_core.c and mod_so.c.

    I downloaded the php-3.0.9.tar.gz from php3.com and even I recomiled apache and php3 with no success

    ....any idea
  8. #5
  9. No Profile Picture
    Devshed Newbie (0 - 499 posts)
    Finally it all worked. The problem was with the (some) instructions in the "Database Driven Website". The instructions to configure and make and install are all correct by syntax, but doesn't compile the the Apache with PHP3 module, due to incorrect order or sequence of configuration, make and install so causing the problem. The configure, make and install to be done in a specific order and with different options. The correct information is in the "http://www.php3.com/manual/installation.php3" install instructions. It have 18 clear steps. I followed the steps and reconfigure and make and install and it all worked like a magic in ONE SHOT.
    "SOME ONE NEED TO LOOK AT THE INSTRUCTIONS IN 'Database Driven websites' IT IS INCORRECT AND MADE ME TO WATE VALUABLE HOURS" otherwise you guys are great and overall information about Apache, mySQL and PHP3 are very useful and good work.

    Buy Buy

    : -)

Similar Threads

  1. Pointer problems opening file *formatted*
    By LAKI in forum C Programming
    Replies: 4
    Last Post: February 11th, 2004, 06:06 AM
  2. Replies: 0
    Last Post: February 7th, 2004, 05:19 AM
  3. PHP file upload script trouble
    By casbboy in forum PHP Development
    Replies: 9
    Last Post: February 5th, 2004, 07:42 PM
  4. How to save text to a file?
    By freaker2k4 in forum Perl Programming
    Replies: 2
    Last Post: January 31st, 2004, 01:35 PM
  5. Replies: 0
    Last Post: January 21st, 2004, 04:25 PM

IMN logo majestic logo threadwatch logo seochat tools logo