#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2000
    Location
    Hong Kong
    Posts
    47
    Rep Power
    15
    Dear all,

    After I have installed php3 and apache, I cannot find libphp3.so... how to install it or how can I get it?

    Thx a lot~~!!

    Jester
  2. #2
  3. No Profile Picture
    freebsd
    Guest
    Devshed Newbie (0 - 499 posts)
    Check this.. http://www.devshed.com/Talk/Forums/F...ML/001087.html

    >>I have tried to give a full path of it...
    >>However , the "Invaild command" still appears... I have tried to use "Loadmodule" to load
    >>other modules... the result is the same..."Invaild command"
    You can't load any modules you like without verifying their existence in the first place.

    >>Invalid command 'LoadModule', perhaps mis-spelled or
    >>defined by a module not included in the server configuration
    I already replied with this: "So have you really checked the existence for libphp3.so?"
    If libphp3.so doesn't exist on your system, you then can't load it with LoadModule directive.
    #############################################
    Read this again: http://www.devshed.com/Talk/Forums/F...ML/001030.html and FIND OUT where (the full path) apxs is. Then re-run 'configure' of your PHP.
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2000
    Location
    Hong Kong
    Posts
    47
    Rep Power
    15
    Dear FREEBSD,

    Thx for your help.. coz I am new in it... And now I think it's ok...!!

    However, when I type "./configure --with-apxs=/usr/local/apache/bin/apxs --with-mysql" in php-3.0.16, it said "apxs links seems broken... and when I make it... it said error in apxs ... is the apache got wrong? But my Apache is running normally if not run php3... any suggestion?

    Thx again~!!

    Jester
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2000
    Location
    Hong Kong
    Posts
    47
    Rep Power
    15
    Hi, me again.

    I have copied the message down. It said:

    "==================================================================
    WARNING: Your /usr/local/apache/bin/apxs script is most likely broken.

    Please go read http://www.php.net/FAQ.php3#4.11 and make the
    changes described there and try again.
    =================================================================="

    What it means? And how can I fix it? Thx a lot~!!

    Jester
  8. #5
  9. No Profile Picture
    freebsd
    Guest
    Devshed Newbie (0 - 499 posts)
    It should be http://www.php.net/FAQ.php3#6.11 instead.
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2000
    Location
    Hong Kong
    Posts
    47
    Rep Power
    15
    Dear Freebsd,

    Thank you very very much~~!! ^_^
    The problem can be solved now~!!
    Thx for your help~~

    Jester

Similar Threads

  1. Replies: 2
    Last Post: February 8th, 2004, 12:56 PM
  2. stl map find with key a class
    By sevgolds in forum C Programming
    Replies: 2
    Last Post: January 27th, 2004, 06:33 AM
  3. Replies: 0
    Last Post: January 18th, 2004, 06:17 AM
  4. parse error cant find problem
    By JamminMun2 in forum PHP Development
    Replies: 3
    Last Post: November 27th, 2003, 08:29 AM
  5. How to find totals
    By Mark_php in forum MySQL Help
    Replies: 6
    Last Post: November 23rd, 2003, 04:55 PM

IMN logo majestic logo threadwatch logo seochat tools logo