#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2000
    Posts
    3
    Rep Power
    0
    im a newbie and tried to install php4 and when i tried to restart the apache server it says Cannot add module via name 'mod_php4.c': not in list of loaded modules.

    i recognize some error during the make install...where says cp: modules/* no such file or directory.. pls help me
  2. #2
  3. No Profile Picture
    freebsd
    Guest
    Devshed Newbie (0 - 499 posts)
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2000
    Posts
    3
    Rep Power
    0
    i did do that way..infact i did follow the guidelines.....still i have the error..i just cant start my apache....anyway i got a question the libphp4.so is it suppose to be under libexec under apache? or where?
  6. #4
  7. No Profile Picture
    freebsd
    Guest
    Devshed Newbie (0 - 499 posts)
    >>i did follow the guidelines.....still i have the error

    May I know what error at which particular step?

    >>is it suppose to be under libexec under apache?
    It could be anywhere you like. I prefer to keep everything under Apache directory (/usr/local/apache/libexec/*) despite the default location for FreeBSD is (/usr/local/libexec/apache/*)

    Let say your ServerRoot directive in your httpd.conf defined as "/usr/local"
    LoadModule vhost_alias_module libexec/apache/mod_vhost_alias.so
    This means libexec is a relative path to your ServerRoot directory which is /usr/local/libexec/apache
    You may also specify the full path like:
    LoadModule vhost_alias_module /usr/local/libexec/apache/mod_vhost_alias.so
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2000
    Posts
    50
    Rep Power
    14
    Yeah try checking the httpd.conf file.
    maybe the modphp4.c module name is dissabled.
    enable it.
  10. #6
  11. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2000
    Posts
    3
    Rep Power
    0
    i did re-install the php4...and i successfully eliminate the error of cp: modules/* no such file or directory....but i have problem when i tried to start the apache server....it still say....mod_php4.c is not in the list of loaded module....

    i checked the http.conf...it's just perfect...i got LoadModule php4_module libexec/libphp4.so
    as well as AddModule mod_php4.c in the clear module list....

    by the way how to enable the mod_php4.c?

Similar Threads

  1. HTML File Icon missing!
    By w2share in forum Windows Help
    Replies: 33
    Last Post: May 16th, 2010, 05:20 PM
  2. formMail - recipient missing
    By bellcom in forum HTML Programming
    Replies: 2
    Last Post: October 31st, 2003, 01:39 PM
  3. adding missing FROM-clause entry for table
    By kurious in forum PostgreSQL Help
    Replies: 0
    Last Post: October 23rd, 2003, 09:10 AM
  4. create view error !! (missing parenthesis error)
    By Dipesh in forum Oracle Development
    Replies: 3
    Last Post: October 16th, 2003, 02:56 PM
  5. how to find the missing in frontpage???
    By worldtouch in forum HTML Programming
    Replies: 1
    Last Post: November 10th, 2001, 08:54 PM

IMN logo majestic logo threadwatch logo seochat tools logo