Hi,

I'm very confused about why get_browser isn't
working properly with my php4. The server is
Apache 1.3.12 on Solaris. Php3 is running
fine, we installed php4 on a different port
to test. I've been reading the comments in
the docs on php.net, and it looks like
get_browser works for some installations and
not others, but I can't figure out why.

Oh, and php4 is 4.0.1pl2.

With the same code and browscap.ini file,
here's what I get with php3 and php4:

php3:
Mozilla/4.74 [en] (WinNT; U)

browser_name_pattern: Mozilla/4.7.*
parent: Netscape 4.0
platform: wildcardcatch
majorver: 4
minorver: 7
browser: Netscape


php4:
Mozilla/4.74 [en] (WinNT; U)

0:

Any suggestions or additional information is
greatly appreciated.

Thanks,
Melissa