Thread: Strange message

    #1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2000
    Posts
    29
    Rep Power
    0
    Hi,

    I posted here a while ago with a sessions.
    Now I got everything working more or less smoothly, but now I am getting a stupid message before any php script outputs:

    For sessions:
    X-Powered-By: PHP/4.0.0 Expires: Thu, 19 Nov 1981 08:52:00 GMT Cache-Control: no-cache, post-check=0, pre-check=0 Pragma: no-cache Content-type: text/html

    For any other scripts:
    X-Powered-By: PHP/4.0.0 Content-type: text/html

    In other words, before any other text appears on the page, one of the above messages appears.
    This is really bothersome to have this appear in every single output page. Why did this start happening and how can I get rid of it??


  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Posts
    43
    Rep Power
    15
    This may be related:

    expose_php = On ; Decides whether PHP may expose the fact that it is installed on the
    ; server (e.g., by adding its signature to the Web server header).
    ; It is no security threat in any way, but it makes it possible
    ; to determine whether you use PHP on your server or not.

    This is int the php.ini file.


    ------------------
    lhallusa
    webpatron.com

    [This message has been edited by lhallusa (edited July 24, 2000).]
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2000
    Posts
    29
    Rep Power
    0
    Thanks for the reply.
    I already thought of this and turned it OFF...however, this only gets rid of the

    "X-Powered-By: PHP/4.0.0"

    line. Everything else stays. Strangely, this started happening just as I defined the session_save.path as c:/windows/temp in php.ini.
    I've gone through the php.ini file, but I can't seem to find anything that could be related to this message. Other suggestions??
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2000
    Posts
    60
    Rep Power
    15
    In php.ini comment out (using all of the Windows Extensions. I ran into this with the switch from PHP3 to PHP4 which doesn't use any of those extensions.
  8. #5
  9. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2000
    Posts
    29
    Rep Power
    0
    aarongb, son of a gun! you're right!
    I had "mysql" uncommented in windows extensions and it worked. I'll have to see if mysql will work after this.

    Thanks a lot!

Similar Threads

  1. Free message board hosting, 30 skins, 11 languages.
    By EDKHosting in forum Web Hosting Offers
    Replies: 1
    Last Post: October 8th, 2008, 06:26 PM
  2. Aligning messages in date and then message ID order
    By rapidwiz in forum MySQL Help
    Replies: 2
    Last Post: October 26th, 2003, 02:15 AM
  3. changing the buttons in the message box
    By crackerweb in forum Visual Basic Programming
    Replies: 6
    Last Post: October 23rd, 2003, 06:36 PM
  4. Replies: 3
    Last Post: October 5th, 2003, 02:10 PM
  5. Unknown column '60A15/F/Br' in 'field list' error message
    By juanito in forum PHP Development
    Replies: 1
    Last Post: October 2nd, 2003, 09:35 AM

IMN logo majestic logo threadwatch logo seochat tools logo