#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2000
    Location
    The Netherlands
    Posts
    13
    Rep Power
    0
    I get the following error when I trie to connect to mysql with mysqlgui.exe

    Warning: MySQL Connection Failed: Can't Connect to MySQL server on 'localhost' (10061)

    But mysql server is running (using mysqld.exe) on my win98 machine (The green light of WinMysqlAdmin is) and I can ping localhost.

    Can anyone help me with this. My my.ini is pasted below.

    Chris

    my.ini:
    #This File was made using the Winmysqladmin 1.0 Tool
    #14-08-2000 10:25:40

    #Uncomment or Add only the keys that you know how works.
    #Read the MySQL Manual for instructions

    [mysqld]

    basedir=c:apachemysql
    bind-address=192.168.0.2
    datadir=c:apachemysqldata
    #language=c:Program Filesmysqlsharedutch
    delay-key-write-for-all-tables
    log-long-format
    ansi
    new
    port=3307
    safe
    skip-name-resolve
    skip-networking
    skip-new
    skip-host-cache
    set-variable=key_buffer=16M
    set-variable=max_allowed_packet=1M
    set-variable=thread_stack=128K
    set-variable=flush_time=1800

    [mysqldump]

    quick
    set-variable=max_allowed_packet=16M

    [mysql]

    no-auto-rehash

    [isamchk]

    set-variable=key=16M

    [Winmysqladmin]

    Server=c:/apache/mysql/bin/mysqld-opt.exe

    user=root
    password=test
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2000
    Posts
    60
    Rep Power
    15
    Create a file C:my.cnf with the following contents ONLY (yes, slashes are pointed the right way):

    [mysqld]
    basedir=C:/apache/mysql/

    MySQL looks for itself in the default directory of C:mysql on Win32.
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2000
    Location
    The Netherlands
    Posts
    13
    Rep Power
    0
    I connect with the internet trough a gateway. In my tcp/ip settings of my networkcard (connected with the ethernet), I had my DNS enabled. After disableing my DNS, everything worked.
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2000
    Location
    London/UK
    Posts
    91
    Rep Power
    15
    sounds like localhost was resolving to 127.0.0.1 but you've specified 192.168.0.2
    c:windowsHosts.sam editied and renamed to Hosts would prolly sort that

    Bealers

    ------------------
    http://back-end.org
  8. #5
  9. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2000
    Location
    The Netherlands
    Posts
    13
    Rep Power
    0
    thanks, now I know why.

Similar Threads

  1. Mysql problem.
    By Nik in forum MySQL Help
    Replies: 54
    Last Post: December 21st, 2006, 07:02 PM
  2. mysql connect issue
    By slen in forum MySQL Help
    Replies: 1
    Last Post: February 17th, 2004, 04:33 AM
  3. problem connecting to mysql server on the network
    By ash_freak in forum MySQL Help
    Replies: 3
    Last Post: February 9th, 2004, 05:29 PM
  4. Replies: 1
    Last Post: February 5th, 2004, 12:50 AM
  5. how to connect the oracle server
    By arihandro in forum Oracle Development
    Replies: 1
    Last Post: February 4th, 2004, 09:30 AM

IMN logo majestic logo threadwatch logo seochat tools logo