#1
  1. A Change of Season
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Mar 2004
    Location
    Next Door
    Posts
    2,672
    Rep Power
    171

    Forbidden You don't have permission to access /todo/ on this server.


    Hello;

    I created a folder on the root directory of the server and uploaded some files to it wanting it to be for public access. The permissions are 777 but I get this when I try to access it:
    Forbidden

    You don't have permission to access /todo/ on this server.
    Apache/2.2.15 (CentOS) Server at hotels2go.com.au Port 80
    What is a girl to do to fix this?

    Thank you
  2. #2
  3. Code Monkey V. 0.9
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Mar 2005
    Location
    A Land Down Under
    Posts
    2,122
    Rep Power
    1990
    The root directory of the server, or the root directory of your hosting account? For the sake of sanity, I'm going to assume that it's your hosting account location that you're talking about here.

    Is this in the public area of your site? Like /public_html/todo/ (on cPanel) as an example? If that's the case it should work, mostly even without 777 permissions. If it doesn't then you'll need to contact your hosting company and ask them to fix whatever permissions lock-downs they have in place.
  4. #3
  5. Transforming Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    14,143
    Rep Power
    9398
    You'll also get that error if (1) you're browsing to a directory, (2) there's no DirectoryIndex file (eg, index.html or index.php), and (3) there's an Options directive that denies Indexes, which is how Apache is configured by default.

    Comments on this post

    • Catacaustic agrees
  6. #4
  7. A Change of Season
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Mar 2004
    Location
    Next Door
    Posts
    2,672
    Rep Power
    171
    Hello;

    It is located at a location like http://www.example.com/todo

    I always share public files like this on other servers. But I am not sure why this is not working. Of course I can make an index.php file and show a list of all the files in the directory but I wonder why I get this error here without the index.php!

    It looks like I can't access any of the folders under public_html.
  8. #5
  9. Code Monkey V. 0.9
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Mar 2005
    Location
    A Land Down Under
    Posts
    2,122
    Rep Power
    1990
    In that case, requinix is correct.
  10. #6
  11. Transforming Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    14,143
    Rep Power
    9398
    (coughnumberthree)

    In the root .htaccess,
    Code:
    Options +Indexes
    Just remember that every directory without an index file will list its contents. Or you can put that directive in a per-directory .htaccess to allow browsing in only specific places.

IMN logo majestic logo threadwatch logo seochat tools logo