Hi,

I have recently installed PostgreSQL 9.2 on my Windows 7 64bit computer. In
addition I have installed Python 3.3. I am new to PostgreSQL, and wish to
play with its support for Python.

I tried to run the command:

CREATE EXTENSION plpython3u

Only to receive the error:

Could not load library "C:/Program Files/PostgreSQL/9.2/lib/plpython3.dll"

Looking at plpython3.dll in Dependency Walker showed that 3 files could not be linked: (have a screenshot but can't attach it as I am a newbie)

a) LIBINTL-8.DLL and POSTGRES>EXE actually exist on my system. This appears
to suggest some sort of environment problem.

b) PYTHON32.DLL doesn't exist on my machine (I only have python3.dll). This
would suggest that perhaps the (latest) version of Python I have is not
comptaible

Can anyone shed some light on the problems I am having? I cannot see what
environment variables need to be set (the docs I have read specify nothing).
In addition, no requirements for the supported versions of Python are
defined.

Any ideas? Anyone???