#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2002
    Posts
    1
    Rep Power
    0

    postgres is too verbose!


    HI,

    I have postgres running as user postgres:

    postmaster -i -D /var/lib/pgsql/data &

    but when I go into my database, say 'addresses' and view the table I get all sorts extra spurious verbose studd that I would prefer not to see.

    promtp]psql addresses
    020314.17:59:13.391 [1551] read_pg_options: verbose=2,query=2,syslog=0
    020314.17:59:13.392 [1551] started: host=localhost user=postgres database=addresses
    020314.17:59:13.392 [1551] InitPostgres
    020314.17:59:13.396 [1551] reset_client_encoding()..
    020314.17:59:13.396 [1551] reset_client_encoding() done.
    020314.17:59:13.397 [1551] StartTransactionCommand
    020314.17:59:13.397 [1551] query: select getdatabaseencoding()
    020314.17:59:13.398 [1551] ProcessQuery
    020314.17:59:13.398 [1551] CommitTransactionCommand
    020314.17:59:13.399 [1551] StartTransactionCommand
    020314.17:59:13.399 [1551] query: SELECT usesuper FROM pg_user WHERE usename = 'postgres'
    020314.17:59:13.402 [1551] ProcessQuery
    020314.17:59:13.402 [1551] CommitTransactionCommand
    Welcome to psql, the PostgreSQL interactive terminal.

    Type: \copyright for distribution terms
    \h for help with SQL commands
    \? for help on internal slash commands
    \g or terminate with semicolon to execute query
    \q to quit

    addresses=#


    ....so all this stuff is superfluous to the proceedings. ANy way I can get rid of this?

    ALso when I do SELECT * FROM table I get:

    020314.18:00:55.982 [1551] StartTransactionCommand
    020314.18:00:55.982 [1551] query: SELECT * FROM names;
    020314.18:00:55.983 [1551] ProcessQuery
    020314.18:00:55.984 [1551] CommitTransactionCommand
    userid | first | surname | email
    ---------+--------+---------------+-------------
    jd1234 | jon | doe | jon.doe
  2. #2
  3. No Profile Picture
    Gödelian monster
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Jul 1999
    Location
    Central Florida, USA
    Posts
    2,307
    Rep Power
    62
    Open your postgresql.conf configuration file (probably /var/lib/pgsql/data/postgresql.conf). Look for the area called "Debug display", and see what your debug level is. Default setting is 0, which just gives you a standard terminal client in psql, and only displays fatal errors. If the setting is higher, try changing it to 0 and restarting postmaster.
    The real n-tier system:

    FreeBSD -> PostgreSQL -> [any_language] -> Apache -> Mozilla/XUL

    Amazon wishlist -- rycamor (at) gmail.com

IMN logo majestic logo threadwatch logo seochat tools logo