#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2010
    Posts
    17
    Rep Power
    0

    PostgreSQL on Win 10...server running?


    Update (1/17/17): OK. This is odd. Booted up my Win 10 sys and the PostgreSQL server was up and running. In the This PC/Manage/Services tab I now find all three buttons: Start, Restart and Stop. Seems like something related to timing with Win 10 start up. I found this to be an occasional problem in Fedora, as well. Someone on the Fedora forum suiggested it could be related to network startup timing issues.

    Anyone have any insight about this? Thx.

    --------------------------------------------------------------------------

    I've messed around with PostgreSQL for quite some time (both on Fedora and Win 7). I now have it on my Win 10 sys.

    When I look at This PC/Manage/Services I notice that the PostgreSQL server is not running. I thought I've seen it running sometime in the past. There is a Start button but no Restart or Stop.

    If I press Start, it looks like the server starts and then I get a message of the sorts "The postgresql-x64-9.6 - PostgreSQL Server 9.6 on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs". Is this normal? Has something changed in 9.6?

    In the past I've always seen the server running. Should I be scanning my log files for something keeping the server from starting?

    Any help appreciated...thx...
    Last edited by stephr1; January 17th, 2017 at 10:53 AM. Reason: Updated info

IMN logo majestic logo threadwatch logo seochat tools logo