#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2001
    Location
    canada
    Posts
    2
    Rep Power
    0

    Cool psql start error


    I've setup an account on my Linux box of postgres. But when I try to run psql I get this error;

    psql: connectDBStart() -- connect() failed: Connection refused
    Is the postmaster running at 'localhost'
    and accepting connections on Unix socket '5432'?

    Anyone know how to fix this? I've got mysql running fine on Linux, but I'd like to experiment with postgres too. Thx.
  2. #2
  3. Modding: Oracle MsSQL Firebird
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2001
    Location
    Outside US
    Posts
    8,527
    Rep Power
    539

    Where is the ### script?


    Looking on PgAccess site I found a tutorial which suggests a solution:

    If you have installed the prewritten script to start postgreSQL automatically, this option is (currently) commented out:

    # PGOPTS="-i"

    just remove the hash and space and comment out the "blank" option above:

    PGOPTS=""

    My question is:
    "Where the hell is that script????'"

    Thanks in advance for your help.

    Pabloj
  4. #3
  5. Modding: Oracle MsSQL Firebird
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2001
    Location
    Outside US
    Posts
    8,527
    Rep Power
    539

    Wink OK


    I've found the answer, I'm posting it here for others who might be interested:

    On Mdk 8.0 edit: /var/lib/pgsql/data/postmaster.opts.default and add:
    -i 5432

    Default db is postgres and user is the same.

IMN logo majestic logo threadwatch logo seochat tools logo