Thread: simple question

    #1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2003
    Posts
    16
    Rep Power
    0

    simple question


    This might sound as a very silly question. But this will make my life easier. Actually I want to enable the support of keyboard arrow keys that repeats the history commands on the postgresql prompt. In my old system happened automatically without settign anything. But in my new system , if I press -> or <- , I get control charactes without te command history. Is there any way to set this? Please advice. Now, every time I need to type in the commands and can't use the command if it's already used once as a previous query at the prompt. These arrows works at postgresql user prompt but not when i goto
    "psql databasename" (database prompt)
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2003
    Posts
    373
    Rep Power
    12
    what operating system are you running the new system on? are you doing it remotely or at your computer? what version of the database software are you using?
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2003
    Posts
    16
    Rep Power
    0
    I am using Mandrake linux 9.1 and postgresql version 7.3.2
    And I am on my computer and not doing the remote access. Even if I do remote access to my old system from my new system, the up and down arrow keys work.
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2003
    Posts
    373
    Rep Power
    12
    it could be the type of terminal or console you're using, try using a different one. (xterm, whatever...)
  8. #5
  9. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2003
    Posts
    16
    Rep Power
    0
    this problem is only for the database prompt. Say if my database name is xweb , before I say psql xweb the up and down arrow keys work fine. But when I goto xweb prompt the arrows stop working and I get some control characters.
  10. #6
  11. Me likey breadsticks...
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Jan 2003
    Location
    Los Angeles
    Posts
    1,189
    Rep Power
    18
    Did you install from source or an RPM? Sounds like it's a problem with Postgres not seeing readline when you installed. Try doing a search on google, or groups.google.com for psql readline or psql up arrow.

    You may have to reconfigure and recompile.

    HTH,
    -b
    PostgreSQL, it's what's for dinner...
  12. #7
  13. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2003
    Posts
    16
    Rep Power
    0
    thanks,
    I was about to post a reply saying it;s problem with readline as I compared adn analysed the difference in files between my old system and the new. I suddenly recollected that while installing postgresql, I had an error for realine library and I had configured with --without-readline option. So, now I installed readline library and reconfigured postgresql and yet to see if everything works fine!!!
    Thanks for the thoughts.
    Veena

IMN logo majestic logo threadwatch logo seochat tools logo