#1
  1. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Location
    Rio de Janeiro, Brazil
    Posts
    447
    Rep Power
    12

    pg_hba.conf all ip addresses


    I was wondering what to put on pg_hba.conf to let all ip address access the database with ssl authentication?
    Help my country and sign the petition in favor of OS software. See the Petition
    Linux is like sex, it's better when it's free!
  2. #2
  3. Me likey breadsticks...
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Jan 2003
    Location
    Los Angeles
    Posts
    1,189
    Rep Power
    18
    Have you tried:

    Code:
     hostssl    all         all         0.0.0.0         0.0.0.0  password
    This should allow access to all databases from any user with password authentication.
    PostgreSQL, it's what's for dinner...
  4. #3
  5. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Location
    Rio de Janeiro, Brazil
    Posts
    447
    Rep Power
    12
    It's saying Error connecting to server, fatal. No entry in pg_hba.conf for server **** user *** database ***
    But it's connecting without the ssl. hmm strange.
    maybe it's because ssl isn't installed?
    Help my country and sign the petition in favor of OS software. See the Petition
    Linux is like sex, it's better when it's free!
  6. #4
  7. Me likey breadsticks...
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Jan 2003
    Location
    Los Angeles
    Posts
    1,189
    Rep Power
    18
    Do you have ssl enabled in your postgresql.conf?
    PostgreSQL, it's what's for dinner...
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2013
    Posts
    1
    Rep Power
    0
    Originally Posted by bcyde
    Have you tried:

    Code:
     hostssl    all         all         0.0.0.0         0.0.0.0  password
    This should allow access to all databases from any user with password authentication.
    For the sanity of anyone else searching for this solution, I had to enter

    host all all 0.0.0.0/0 md5

    Of course no password auth, but I'm in a development setting and dont have time for that. (Postgres 9.2)

    Thanks

IMN logo majestic logo threadwatch logo seochat tools logo