I'm using postgresql 7.3.2 RPMs for SuSE 8.2 and I'm having difficulty getting the server to use a different port (the same one as my webhost).

It works if I su to postgres and start the server manually with postmaster -D ~postgres/data -i -p 5433

However, trying to start the server with pg_ctl or automatically with init.d (rc.d) and passing options to postmaster that way doesn't work. (Line from /etc/init.d/postgresql: pg_ctl start -s -w -p $H -l $LOGFILE -D $DATADIR -o "\"$OPTIONS\"") Neither does setting the port in ~postrgres/data/postgresql.conf.

Other than that the server works fine. Any help, please?