I posted this originally on the Fedora forum and received no responses so I thought I'd check in here and see if anyone can shed some light on this for me.

I had originally set (postgresql.conf) listen_address= 'localhost, <ip addr>' (where <ip addr> is the fixed/manual ip addr of the PostgreSQL server host (I also tried in place of localhost). I kept getting log messages of the sort "socket not available...", "Is another .....". etc. and when I tried to access a db, I got back "...server not listening....", etc. msgs (system-config-services GUI did seem to show the server *was* running).

Responses I've gotten on this topic typically had to do with the timing of the network server being up vs. when the PostgreSQL server tried to come up and network resources either were not available or not ready (I did try to alter the PostgreSQL server bootup sequence a couple of times using disable/enable and maybe even a reinstall with no effect).

Then I decided to try an experiment. I changed listen_address back to the '*' wildcard and checked PostgreSQL boot up. Now it works and has been working (at least, for a while).

So, my question is if this is a boot up sequence issue (and, intuitively, if feels like it could be), why would PostgreSQL boot up as expected (using '*'), yet when using more specific ip addr settings ('localhost, '<ip addr>'), PostgreSQL chokes?

Would love to figure this out...Thanks.....