Thread: Open GLFreelut

    #1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2013
    Location
    Antwerpen Merksem
    Posts
    1
    Rep Power
    0

    Open GLFreelut


    after i include :

    #include <gl/freeglut.h>

    the debugger shows me a run flout on.

    obj\Debug\main.o||In function `glutInit_ATEXIT_HACK':|
    \include\gl\freeglut_std.h|612|undefined reference to `_imp____glutInitWithExit@12'|
    obj\Debug\main.o||In function `glutCreateWindow_ATEXIT_HACK':|
    .\include\gl\freeglut_std.h|614|undefined reference to `_imp____glutCreateWindowWithExit@8'|
    obj\Debug\main.o||In function `glutCreateMenu_ATEXIT_HACK':|
    .\include\gl\freeglut_std.h|616|undefined reference to `_imp____glutCreateMenuWithExit@8'|
    ||=== Build finished: 3 errors, 0 warnings (0 minutes, 0 seconds) ===|


    Code:
    static void FGAPIENTRY FGUNUSED glutInit_ATEXIT_HACK(int *argcp, char **argv) { __glutInitWithExit(argcp, argv, exit); }



    i am to get tutorial http://ogldev.atspace.co.uk/
    to work.
  2. #2
  3. Contributed User
    Devshed Specialist (4000 - 4499 posts)

    Join Date
    Jun 2005
    Posts
    4,392
    Rep Power
    1871
    > the debugger shows me a run flout on.
    No, what you're seeing are error messages from the linker.

    What command did you type to build? Was it gcc or make?
    Show us what you did.
    If you dance barefoot on the broken glass of undefined behaviour, you've got to expect the occasional cut.
    If at first you don't succeed, try writing your phone number on the exam paper

IMN logo majestic logo threadwatch logo seochat tools logo