#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2003
    Posts
    58
    Rep Power
    12

    Urgent:Problems transferring C++ executable files on another machine


    Hello

    I created some executable files out of a particular Code using Turbo C++. Those executables were working fine when i checked on my machine in any path . When i transferred those files to another machine which does not have turbo C++ in it then it doesn't run properly. why is this happening ideally the executables should work fine in any machine with or without C++ on it.

    I tried to look up some linker options in TurboC++ but could not find anything useful..plss let me know about this as soon as possible.i think that has something to do with dynamic linking..


    Thanks so much

    Ravi
  2. #2
  3. I'm Baaaaaaack!
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Jul 2003
    Location
    Maryland
    Posts
    5,538
    Rep Power
    244
    Didn't dwise1_aol already try to help you with that? Did you follow his advice?

    My blog, The Fount of Useless Information http://sol-biotech.com/wordpress/
    Free code: http://sol-biotech.com/code/.
    Secure Programming: http://sol-biotech.com/code/SecProgFAQ.html.
    Performance Programming: http://sol-biotech.com/code/PerformanceProgramming.html.
    LinkedIn Profile: http://www.linkedin.com/in/keithoxenrider

    It is not that old programmers are any smarter or code better, it is just that they have made the same stupid mistake so many times that it is second nature to fix it.
    --Me, I just made it up

    The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore, all progress depends on the unreasonable man.
    --George Bernard Shaw
  4. #3
  5. Contributing User
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jan 2003
    Location
    USA
    Posts
    7,175
    Rep Power
    2222
    OK, now I'm at the office and can look it up in the manuals.

    Borland C++ 3.1 User's Guide pages 106 to 109, "Linker":

    Get there via the IDE Main Menu: Options | Linker | Libraries

    There are four panes in the dialog box that pops up.

    In the Standard Run-time Libraries pane are three radio buttons:
    ( ) None
    ( ) Static
    ( ) Dynamic

    Yours is probably set to Dynamic. Change it to Static and click on OK.

    BTW, the same instructions appear in the Borland C++ 3.0 documentation.

IMN logo majestic logo threadwatch logo seochat tools logo