#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2003
    Posts
    11
    Rep Power
    0

    ActiveState Python, not loading after first time viewing


    I am using ActiveState Python in my ASP code, (First Example)

    The first time I load the page it works fine, anytime after that all I get is a blank page(Second Example).

    If I resave the file then it works again, but only once.

    I just installed Python onto the Server. (windows 2000)

    Anyone have any Idea's?


    ***************************************
    <html><head>
    <title>Bob</title>
    </head>
    <body>
    <%@ Language = Python %>
    <%
    Response.Write("Test")
    %>
    </body>
    </html>

    ***************************************
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML><HEAD>
    <META http-equiv=Content-Type content="text/html; charset=windows-1252"></HEAD>
    <BODY></BODY></HTML>
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2003
    Posts
    11
    Rep Power
    0

    Slightly better explenation.


    After playing around with a little more, I have figured out that it is simply not displaying anything at all after the first time it runs.
    ----------------------------------------
    test
    <%@ LANGUAGE = Python %>
    ----------------------------------------


    The above source code will send test to the browser the first time I goto the page.

    The second time I go to the page, nothing is generated.

    If I use vbscript it works fine.

    Devolpment on my site continues, but If I can't fix this then I can deploy it.

    If anyone has any Idea's I would very much appriciate it.
  4. #3
  5. Hello World :)
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Mar 2003
    Location
    Hull, UK
    Posts
    2,537
    Rep Power
    69
    I don't know, this sounds like a setup/server thing, you'r not actually doing anything with Python that could cause this, infact from what i can see your not doing anything with Python at all. You might get a better reponce form the ASP forum.

    One minor point, i thought the <%@ LANGUAGE = Lang %> had to be the first line in ASP? I'm not sure where I picked this up but..

    If I figure somthing out then I will let you know,
    Mark.
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2003
    Posts
    11
    Rep Power
    0

    Problem Solved


    I just found the problem and resolved it.

    Apartently this is a known bug in the 2.2.x release.

    -------------------------------------------------------------------------------
    This ia a bug I am hoping to fix very soon. If you are really keen,
    then you can grab the framework.py from win32all-142.exe - you can open
    that .exe using WinZip.

    - Mark Hammond
    -------------------------------------------------------------------------------


    http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&threadm=vtk68.20338%248d1.7162721%40news1.rdc1.md.home.com&rnum=1&prev=/groups%3Fhl%3Den%26lr%3D%26ie%3DUTF-8%26oe%3DUTF-8%26q%3Dasp%2Bpython%2Brefresh
  8. #5
  9. Hello World :)
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Mar 2003
    Location
    Hull, UK
    Posts
    2,537
    Rep Power
    69
    good tracking, So how did you manage to solve the problem just out of interest? I've been interested in using Python with ASP but i dont like windows servers so i havnt taken it any further, maybe one day I will. Is the interface to ASP framework.py or an exe?

    Mark.
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2003
    Posts
    11
    Rep Power
    0
    Basically I just hunted on google for a couple of hours until I found other people who had the same problem.

    This issue aside, using Python for ASP works very well.

    It was pretty easy to install, and works far better then vbscript.

    Oh, and I hate working on a window's server too, but I doubt I could get permission to install linux; this is the next best thing.

IMN logo majestic logo threadwatch logo seochat tools logo