#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2003
    Location
    Euless, TX
    Posts
    6
    Rep Power
    0

    Angry Can't get Idle started on XP


    I'm new to python and fairly new to programming so be gentle. I just installed 2.3.3 on my XP machine and tried opening Idle and get nothing but an hourglass for a second next to my cursor. Is this a common problem? I've uninstalled and reinstalled and still get nothing. I know you can use other means, but the books I'm learning python from use Idle so I would like to be able to follow along smoothly. Any help is appreciated and I apologize if you've heard this before. Thanks.
  2. #2
  3. Hello World :)
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Mar 2003
    Location
    Hull, UK
    Posts
    2,537
    Rep Power
    69
    Mmm, all i can think of is that you didnt install Tk/Idle when you installed Python... these options should already be selected when you first run the exe.

    So I'd first try reinstalling Python again just to make sure all the options are selected!

    Let me know how it goes,

    Mark.
    programming language development: www.netytan.com Hula

  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2003
    Location
    Euless, TX
    Posts
    6
    Rep Power
    0
    Thanks Mark for your help. I did a reinstall and made sure installation of Tk/Idle was checked like you said. Still nothing. Who knows what's wrong? Anyway, I downloaded PythonWin and it works fine for me. Thanks again for your help.
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2002
    Posts
    89
    Rep Power
    13
    check if the shortcut link is wrong. I remember mine was wrong.
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2003
    Posts
    35
    Rep Power
    12
    Hmmm, a friend of mine had this problem once. If you have firewall software installed (such as ZoneAlarm), try disabling it before starting Idle. No garuantees tho.

    - tps
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2003
    Posts
    35
    Rep Power
    11
    Did you have a version prior to 2.3.3 installed? I did a dual install once, but for some reason the tkinter didn't install seperately (dll's maybe), and idle wouldn't work. Uninstalling one of the versions and reinstalling the version i kept worked. What happens when you run IDLE from the command line (DOS prompt)? Do you get any kind of error messages from it
  12. #7
  13. Hello World :)
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Mar 2003
    Location
    Hull, UK
    Posts
    2,537
    Rep Power
    69
    Assuming you've installed Python in the default directory "C:\Python23" you can open Idle directly by running "C:\Python23\Lib\idlelib\idle.py" instead of "idle.pyw".

    Aswell as solving the shortcut problem (if it works you know its the shortcut) you should see a console window that you can use to check for errors i.e. an ImportError

    Mark.
    programming language development: www.netytan.com Hula

  14. #8
  15. Hello World :)
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Mar 2003
    Location
    Hull, UK
    Posts
    2,537
    Rep Power
    69
    Another solusion, if you right click .py files you should see an 'Edit with Idle' option.

    Mark.
    programming language development: www.netytan.com Hula

  16. #9
  17. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2003
    Location
    Euless, TX
    Posts
    6
    Rep Power
    0
    Ok. Thanks to everybody. I don't know how, but I installed the win32all or whatever it's called from starship and that let Idle start. Again, who knows? Thanks for all your help.

    Justin

IMN logo majestic logo threadwatch logo seochat tools logo