Hi,

I am using python and python-ldap with Apache on Mac OS 10.5. In addition to that I am using mod_python to interact with python via apache(running on 64 bit architecture).

Python and Python-ldap working fine on apache compiled with 32 bit architecture.

However, with our current apache setup , which is of 64 bit, we are facing compatibility issue between Python and Pythan-ldap. I am using python script for svn authentication. My python script is running fine with apache(64 bit architecture too) when I am not using "import ldap" statement. It simply returns "apache.OK". But when I am using "import ldap" statement then it gives me the error mentioned below. My code looks like this :
=======================================
import ldap
from mod_python import apache

def authenhandler(req):
return apache.OK
=======================================


In Apache 64 bit we are getting following error.
==============================================================
ImportError: dlopen(/Library/Python/2.5/site-packages/python_ldap-2.3.13-py2.5-macosx-10.5-i386.egg/_l
dap.so, 2): no suitable image found. Did find:\n\t/Library/Python/2.5/site-packages/python_ldap-2.3.13-py2.5-macosx-10.5-i386.egg/_ldap.so: mach-o, but wron
g architecture\n\t/private/var/root/lib/_ldap.so: stat() failed with errno=13


Please help me on this. Thanks in advance.