Hi all,

I get this error and i'm TOTALLY lost. Dunno how to fix and dunno why its looking for the directory or file 2.4.2.4 (except that its the version of wxpython i'm using) otherwise it appears nowhere in my source code. My program runs fine, but i cant turn it into an exe!

What could be wrong please help!

here's my setup.py file:
------------------------------------------
# setup.py

from distutils.core import setup
import py2exe

setup(name="BLOX", scripts=["blox.py"],
)

------------------------------------------

and here's my cmd line output:

-----------------------------------------
C:\Blox>python setup.py py2exe
running py2exe
running build
running build_scripts
creating build
creating build\scripts-2.2
copying blox.py -> build\scripts-2.2
running install_scripts
creating build\bdist.win32
creating build\bdist.win32\winexe
creating build\bdist.win32\winexe\lib
creating build\bdist.win32\winexe\lib\Program Files
creating build\bdist.win32\winexe\lib\Program Files\Python22
creating build\bdist.win32\winexe\lib\Program Files\Python22\Scripts
copying build\scripts-2.2\blox.py -> build\bdist.win32\winexe\lib\Program Files\
Python22\Scripts
creating dist
+----------------------------------------------------
| Processing script blox.py with py2exe-0.3.3
+----------------------------------------------------
creating dist\blox
creating build\bdist.win32\winexe\collect
creating build\bdist.win32\winexe\collect\blox
creating build\bdist.win32\winexe\collect\blox\Scripts.py2exe
Searching modules needed to run 'blox.py' on path:
['C:\\Blox\\build\\bdist.win32\\winexe\\lib\\Program Files\\Python22\\Lib\\site-
packages', '', 'C:\\Blox', 'C:\\Program Files\\Python22\\DLLs', 'C:\\Program Fil
es\\Python22\\lib', 'C:\\Program Files\\Python22\\lib\\lib-tk', 'C:\\Program Fil
es\\Python22', 'C:\\Program Files\\Python22\\lib\\site-packages']
error: 2.4.2.4: No such file or directory

---------------------------------------------------------

Here's what i'm using:
Python 2.2
wxPythonWIN32-2.4.2.4
py2exe-0.3.3
PyXML-0.8.3

All meant to work with python 2.2

Thanks in advance